InterProScan java issue
1
0
Entering edit mode
2.3 years ago
emilyc ▴ 30

Bonjour,

How do I get my InterProScan to function when the version of java is incorrect.

Java version 1.8 is required to run InterProScan.
Detected version 11.0
Please install the correct version.

Merci pour votre temps/thanks for your time

Emily

java interproscan • 1.4k views
ADD COMMENT
1
Entering edit mode
2.3 years ago

in https://github.com/ebi-pf-team/interproscan/blob/ff63535bfdaba64f9b48fc0c505f2ade85bd9d64/core/jms-implementation/support-mini-x86-32/interproscan.sh#L31

if [[ "${JAVA_MAJOR_VERSION}" == "1" && "${JAVA_MINOR_VERSION}" -lt "8" ]];

checks that the first number is '1" (like in "1.8") but here your version is 11

you can always try to change the script here but beware jdk11 and jdk8 are not compatibles for all librarie (e.g jaxb):

ADD COMMENT
0
Entering edit mode

Thank you. I am getting the following now.

OpenJDK 64-Bit Server VM warning: Option AggressiveOpts was deprecated in version 11.0 and will likely be removed in a future release.
Unrecognized VM option 'UseFastAccessorMethods'
Error: Could not create the Java Virtual Machine.
Error: A fatal exception has occurred. Program will exit.

Not really sure what to make of it.

ADD REPLY

Login before adding your answer.

Traffic: 3101 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6