Question: Error segmentation steps
0
gravatar for Hällyss
5 months ago by
Hällyss50
CHU Angers
Hällyss50 wrote:

Hello

I have an error in my segmentation step (cbs) :

Segmenting with method 'cbs', significance threshold 0.0001, in 1 processes
Traceback (most recent call last):
  File "/usr/local/bin/cnvkit.py", line 13, in <module>
    args.func(args)
  File "/usr/local/lib/python2.7/dist-packages/cnvlib/commands.py", line 632, in _cmd_segment
    processes=args.processes)
  File "/usr/local/lib/python2.7/dist-packages/cnvlib/segmentation/__init__.py", line 61, in do_segmentation
    for _, ca in cnarr.by_arm())))
  File "/usr/local/lib/python2.7/dist-packages/cnvlib/parallel.py", line 26, in map
    return map(func, iterable)
  File "/usr/local/lib/python2.7/dist-packages/cnvlib/segmentation/__init__.py", line 86, in _ds
    return _do_segmentation(*args)
  File "/usr/local/lib/python2.7/dist-packages/cnvlib/segmentation/__init__.py", line 157, in _do_segmentation
    seg_out = core.call_quiet(rscript_path, '--vanilla', script_fname)
  File "/usr/local/lib/python2.7/dist-packages/cnvlib/core.py", line 36, in call_quiet
    % (' '.join(args), err))
RuntimeError: Subprocess command failed:
$ Rscript --vanilla /tmp/tmpMBe2aP

Loading probe coverages into a data frame
Warning message:
In CNA(cbind(tbl$log2), tbl$chromosome, tbl$start, data.type = "logratio",  :
  markers with missing chrom and/or maploc removed

Segmenting the probe data
Error in segment(cna, weights = tbl$weight, alpha = 1e-04) : 
  length of weights should be the same as the number of probes
Exécution arrêtée

Can you help me please ?

cnvkit • 133 views
ADD COMMENTlink modified 5 months ago by ATpoint31k • written 5 months ago by Hällyss50
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 2213 users visited in the last hour