Question: DESEQ2 : plotPCA
0
gravatar for ZheFrench
8 months ago by
ZheFrench300
France
ZheFrench300 wrote:

My environment is R version 3.6.2 & conda 4.8.1.

Something I used to make work doesn't work anymore. It doesn't plot the PCA anymore don't know why. Any advice would be appreciate.

rld <- rlog(dds, blind=FALSE) 

pdf(paste0(c(dir_exploration,"PCA_MDS_plot.pdf"),collapse="/"))

plotPCA(rld,  intgroup = c("condition"))
plotPCA(rld,  intgroup = c("sample_id"))

data <- plotPCA(rld, intgroup = c( "condition"), returnData=TRUE)

percentVar <- round(100 * attr(data, "percentVar"))
ggplot(data, aes(PC1, PC2,  shape=condition)) +   geom_point(size=3) +
 xlab(paste0("PC1: ",percentVar[1],"% variance")) +
  ylab(paste0("PC2: ",percentVar[2],"% variance"))
dev.off()

Error I got :

Error in La.svd(x, nu, nv) : error code 3 from Lapack routine 'dgesdd' Calls: plotPCA ... .local -> prcomp -> prcomp.default
-> svd -> La.svd Execution halted
rna-seq pca deseq2 • 373 views
ADD COMMENTlink modified 8 months ago • written 8 months ago by ZheFrench300
0
gravatar for ZheFrench
8 months ago by
ZheFrench300
France
ZheFrench300 wrote:

Answer :

conda install -c conda-forge lapack

And on top of it I reinstalled DESeq2 with biocmanager did the trick.

ADD COMMENTlink written 8 months ago by ZheFrench300
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 1759 users visited in the last hour