WGCNA not working with R 3.6.2
3
0
Entering edit mode
2.3 years ago

Hi,

I have previously and recently used WGCNA. I updated R to 3.6.2 and the installation of WGCNA is required and not working.

install.packages("WGCNA")

which gives me this response:

Package which is only available in source form, and may need compilation of C/C++/Fortran: ‘WGCNA’

Do you want to attempt to install these from sources? (Yes/no/cancel) Yes

installing the source package ‘WGCNA’

trying URL 'https://cran.rstudio.com/src/contrib/WGCNA_1.68.tar.gz'

Content type 'application/x-gzip' length 1166156 bytes (1.1 MB)

downloaded 1.1 MB

  • installing source package ‘WGCNA’ ... * package ‘WGCNA’ successfully unpacked and MD5 sums checked * using staged installation ** libs xcrun: error: invalid active developer path (/Library/Developer/CommandLineTools), missing xcrun at: /Library/Developer/CommandLineTools/usr/bin/xcrun ERROR: compilation failed for package ‘WGCNA’
  • removing ‘/Library/Frameworks/R.framework/Versions/3.6/Resources/library/WGCNA’ Warning in install.packages : installation of package ‘WGCNA’ had non-zero exit status

The downloaded source packages are in ‘/private/var/folders/nx/_07512cx3cdfz3464ts6glqw0000gn/T/Rtmp9dbXqM/downloaded_packages’

Any help or suggestions is appreciated.

WGCNA installation • 1.9k views
ADD COMMENT
1
Entering edit mode
2.3 years ago

This worked:

xcode-select --install

Thank you, everyone, for your time and help.

ADD COMMENT
0
Entering edit mode
2.3 years ago
tothepoint ▴ 680

Try this:

install.packages("WGCNA", dependencies=TRUE)

ADD COMMENT
0
Entering edit mode

Thank you for your time, devarora, here is my attempt at your suggestion:

install.packages("WGCNA", dependencies=TRUE)

Warning in install.packages : dependencies ‘org.Hs.eg.db’, ‘org.Mm.eg.db’, ‘minet’ are not available also installing the dependencies ‘infotheo’, ‘entropy’

Package which is only available in source form, and may need compilation of C/C++/Fortran: ‘WGCNA’ Do you want to attempt to install these from sources? (Yes/no/cancel) Yes trying URL 'https://cran.rstudio.com/bin/macosx/el-capitan/contrib/3.6/infotheo_1.2.0.tgz'

Content type 'application/x-gzip' length 130670 bytes (127 KB)

downloaded 127 KB

trying URL 'https://cran.rstudio.com/bin/macosx/el-capitan/contrib/3.6/entropy_1.2.1.tgz'

Content type 'application/x-gzip' length 79449 bytes (77 KB)

downloaded 77 KB

The downloaded binary packages are in /var/folders/nx/_07512cx3cdfz3464ts6glqw0000gn/T//RtmpEfzNmA/downloaded_packages installing the source package ‘WGCNA’

trying URL 'https://cran.rstudio.com/src/contrib/WGCNA_1.68.tar.gz'

Content type 'application/x-gzip' length 1166156 bytes (1.1 MB)

downloaded 1.1 MB

  • installing source package ‘WGCNA’ ... * package ‘WGCNA’ successfully unpacked and MD5 sums checked * using staged installation ** libs xcrun: error: invalid active developer path (/Library/Developer/CommandLineTools), missing xcrun at: /Library/Developer/CommandLineTools/usr/bin/xcrun ERROR: compilation failed for package ‘WGCNA’
  • removing ‘/Library/Frameworks/R.framework/Versions/3.6/Resources/library/WGCNA’ Warning in install.packages : installation of package ‘WGCNA’ had non-zero exit status

The downloaded source packages are in ‘/private/var/folders/nx/_07512cx3cdfz3464ts6glqw0000gn/T/RtmpEfzNmA/downloaded_packages’

ADD REPLY
0
Entering edit mode

When such error occurs to me I just manually install the libraries first which are not available. For instance here "dependencies ‘org.Hs.eg.db’, ‘org.Mm.eg.db’, ‘minet’ are not available also installing the dependencies ‘infotheo’, ‘entropy’". Most of the time it works. You could also give a try. Try installing these first and then WGCNA hope this work well.

I have not experienced this but recently I saw somewhere posted in these situation where: Package which is only available in source form, and may need compilation of C/C++/Fortran: ‘WGCNA’ Do you want to attempt to install these from sources? Proceed with "no" and installation was successful.

ADD REPLY
0
Entering edit mode
2.3 years ago
h.mon 34k

You are probably on a Mac (you should have stated your operating system so we don't have to guess), and you should install Apple's XCode.

ADD COMMENT
0
Entering edit mode

so sassy!,

mac

ADD REPLY

Login before adding your answer.

Traffic: 1224 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6