Question: (Closed) DADA2 install help
0
gravatar for cmines98
4 weeks ago by
cmines980
cmines980 wrote:

Hello, I am having trouble downloading DADA2 onto R studio Version 1.1.463

I have tried just about every option on this link:

https://benjjneb.github.io/dada2/dada-installation.html

when using this:

library("devtools")
devtools::install_github("benjjneb/dada2")

I get this error message:

library("devtools")
Loading required package: usethis
Error in loadNamespace(i, c(lib.loc, .libPaths()), versionCheck = vI[[i]]) :
namespace ‘rlang’ 0.1.6 is already loaded, but >= 0.3.0 is required
Error: package or namespace load failed for ‘devtools’

devtools::install_github("benjjneb/dada2")
Error in loadNamespace(i, c(lib.loc, .libPaths()), versionCheck = vI[[i]]) :
namespace ‘rlang’ 0.1.6 is already loaded, but >= 0.3.0 is required

what am I doing wrong and how can I fix it, thank you for any help!!!

dada • 111 views
ADD COMMENTlink modified 9 days ago by Biostar ♦♦ 20 • written 4 weeks ago by cmines980
2

You're using a really old version of rlang. Update the package - the current version if 0.4.4, 0.1.6 is quite prehistoric in terms of software age (August 2017).

ADD REPLYlink modified 4 weeks ago • written 4 weeks ago by RamRS26k

Hello cmines98!

We believe that this post does not fit the main topic of this site.

OP never followed up.

For this reason we have closed your question. This allows us to keep the site focused on the topics that the community can help with.

If you disagree please tell us why in a reply below, we'll be happy to talk about it.

Cheers!

ADD REPLYlink written 9 days ago by ATpoint31k
Please log in to add an answer.
The thread is closed. No new answers may be added.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 1227 users visited in the last hour