Question: Unifiedgenotyper Bug?
0
gravatar for Leandro Batista
5.9 years ago by
Paris
Leandro Batista100 wrote:

Hi everyone,

I'm calling SNPs with UnifiedGenotyper:

java -Xmx2g -jar /Volumes/DroboLeandro/Analysis/Software/GenomeAnalysisTK/GenomeAnalysisTK.jar -T UnifiedGenotyper -R /Volumes/DroboLeandro/Analysis/Genomes/Reference/NCBIM37.chr.fa -I BALBcByJ.recal.bam --dbsnp /Volumes/DroboLeandro/Analysis/dbSNP/dbSNP.vcf --genotype_likelihoods_model SNP --metrics_file BALBcByJ.metrics.snp.txt -stand_call_conf 30 -stand_emit_conf 30 -o BALBcByJ.snp.raw.vcf -log BALBcByJ.UnifiedGen.snp.log

It appears to work fine, without any apparent error. But when I try to run VariantAnnotator on the raw.vcf file output, it gives an error because the VCF file is malformed:

ERROR MESSAGE: The provided VCF file is malformed at approximately line number 237: there aren't enough columns for line 0;FS=0.000;HRun=0;HaplotypeScore=0.0000;MQ=60.00;MQ0=0;QD=33.90 GT:AD:DP:GQ:PL 1/1:0,11:11:33.10:406,33,0

When I look at the region on the VCF, this is what I actually have:

chr4 58379627 rs32247182 A G 1694.62 . AC=2;AF=1.00;AN=2;DB;DP=57;Dels=0.00;FS=0.000;HRun=0;HaplotypeScore=0.8941;MQ=58.03;MQ0=0;QD=29.73 GT:AD:DP:GQ:PL 1/1:0,56:57:99:1728,162,0 chr4 58379655 rs32566361 T C 3398.59 . AC=2;AF=1.00;AN=2;DB;DP=100;Dels=0.00;FS=0.000;HRun=0;HaplotypeScore=1.8662;MQ=58.65;MQ0=0;QD=33.99 GT:AD:DP:GQ:PL 1/1:0,98:100:99:3399,277,0
0;FS=0.000;HRun=0;HaplotypeScore=0.0000;MQ=60.00;MQ0=0;QD=33.90 GT:AD:DP:GQ:PL 1/1:0,11:11:33.10:406,33,0 chr4 58380476 rs32067653 G T 1272.97 . AC=2;AF=1.00;AN=2;DB;DP=39;Dels=0.00;FS=0.000;HRun=0;HaplotypeScore=0.9987;MQ=58.92;MQ0=0;QD=32.64 GT:AD:DP:GQ:PL 1/1:0,39:39:99:1306,114,0

So UnifiedGenotyper is outputting incorrect VCF files with some incomplete lines (the one in bold), where only annotations are present. It is the 5th line, today, in completely independent samples. If I remove these incomplete lines, the downsteam tools will work just fine! But I'm affraid I'm loosing SNPs. Is it a bug on UnifiedGentoyper? Has anyone had the same error?

Thanks, Leandro

gatk • 1.9k views
ADD COMMENTlink modified 2.2 years ago by fufuyou90 • written 5.9 years ago by Leandro Batista100

Hmm... maybe nothing is lost. Are all of the HaplotypeScores = 0.00000. It sounds like a bug, but maybe it only effects calls with 0 confidence?

ADD REPLYlink written 5.9 years ago by John St. John1.0k
0
gravatar for fufuyou
2.2 years ago by
fufuyou90
United States
fufuyou90 wrote:

I have the same problem. Could you tell me how to solve it?

Thanks,

ADD COMMENTlink written 2.2 years ago by fufuyou90
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 726 users visited in the last hour