Biopython vs Python
1
0
Entering edit mode
4.2 years ago
mspingdeng • 0

Hi, Please help -

If already have python 3 in laptop, is biopython still needed to download? I already downloaded python 3; when I checked on the www.bippython.org, there is also "download", are they the same or different?

  • sorry if it is a naive question. Thank you in advance for your kind input.
genome • 2.8k views
ADD COMMENT
1
Entering edit mode

If you need to work with the biopython package, you need that. Think it this way, if you have windows OS, do you need microsoft office ? Answer is yes, if you need powerpoint!

ADD REPLY
0
Entering edit mode

Please help:

after install biopython in pycham, the downloaded sequence file is not recognized by pycham. what can i do? Thank you.

the link below shows how it is after i tried to open the file after download.

ADD REPLY
0
Entering edit mode

Sorry, but without the link, we cannot see what is supposedly wrong. If the installation causes problems for you, did you consider creating a conda environment managing biopython for you (Conda Biopython)?

ADD REPLY
0
Entering edit mode

Thank you for trying to help.

https://ibb.co/nwpZzX3

The above is the link.

I generated a new file, make sure the project interpreter has biopython 1.77, pip3.8. Download the fasta file; however, when try to open it, it says it is not exist. Want to know where step is missing?

Thank you. Best!

ADD REPLY
0
Entering edit mode

Try giving the full path to the file (i.e. where was it downloaded to?). This is not a biopython/python issue, it is just that your script is looking at the wrong path.

ADD REPLY
0
Entering edit mode
4.2 years ago
lumal29 ▴ 80

Hi, Biopython is a bioinformatics package for python, so you will need to install it with pip install biopython in a command line.

ADD COMMENT
0
Entering edit mode

Thank you so much, got it! appreciate very much!

ADD REPLY

Login before adding your answer.

Traffic: 1853 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6