conda installation error in hypo
1
0
Entering edit mode
16 months ago
takoyaki ▴ 90

Hi !
I wanted to polish long read by hypo and meet error when installing through conda.
I couldn't solve this problem, so I want to ask you for help. Below are error messages.

(base) $ conda install -c bioconda hypo

Collecting package metadata (current_repodata.json): done
Solving environment: failed with initial frozen solve. Retrying with flexible solve.
Solving environment: failed with repodata from current_repodata.json, will retry with next repodata source.
Collecting package metadata (repodata.json): done
Solving environment: failed with initial frozen solve. Retrying with flexible solve.
Solving environment: - 
Found conflicts! Looking for incompatible packages.
This can take several minutes.  Press CTRL-C to abort.
failed                                                                                              

UnsatisfiableError: The following specifications were found to be incompatible with each other:

Output in format: Requested package -> Available versions

Package zlib conflicts for:
hypo -> zlib[version='>=1.2.11,<1.3.0a0']
hypo -> kmc[version='>=3.0'] -> zlib[version='1.2.11.*|1.2.8.*']

Package libstdcxx-ng conflicts for:
hypo -> kmc[version='>=3.0'] -> libstdcxx-ng[version='>=7.2.0']
hypo -> libstdcxx-ng[version='>=7.3.0']

Package libgcc-ng conflicts for:
hypo -> kmc[version='>=3.0'] -> libgcc-ng[version='>=7.2.0']
hypo -> libgcc-ng[version='>=7.3.0']

Package _libgcc_mutex conflicts for:
python=3.7 -> libgcc-ng[version='>=7.3.0'] -> _libgcc_mutex=[build=main]
hypo -> libgcc-ng[version='>=7.3.0'] -> _libgcc_mutex=[build=main]

I couldn't understand this error message meanings because these doesn't seem to conflict.
Also, I checked these packages from conda list command.

$ conda list
# packages in environment at /home/user/anaconda3:
#
# Name                    Version                   Build  Channel
zlib                      1.2.11               h7b6447c_3  
kmc                       3.1.2rc1             h2d02072_0    bioconda
libstdcxx-ng              9.1.0                hdf63c60_0  
libgcc-ng                 9.1.0                hdf63c60_0
_libgcc_mutex             0.1                        main

From these version information, I think all packages meet conditions.
How do you think ? What should I do ??

Below are my environment information.

conda version : 4.8.3
conda-build version : 3.18.11
python version : 3.7.6.final.0
platform : linux-64

Thanks in advance.

anaconda sequencing assembly longread hypo • 963 views
ADD COMMENT
2
Entering edit mode
16 months ago
  1. Please remember to use the conda-forge channel as well, we use it in Bioconda for many dependencies.
  2. It's highly recommended to create environments for different tools.

.

conda create -n hypo -c conda-forge -c bioconda hypo
ADD COMMENT
0
Entering edit mode

Thanks, Devon. So, it is better to use different virtual environments to avoid these conflict problem.

Please let me ask you one more question. I think that we use a lot of tools in bioinformatics, so will we create many virtual environments, like hypo, busco, flye, medaka ... and so on ?

ADD REPLY
1
Entering edit mode

Yes, it's good practice to keep tools in separate versioned environments when possible, or at the very least create project-specific environments that you then do not ever change.

ADD REPLY

Login before adding your answer.

Traffic: 2735 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6