Trimmomatic and Salmon error
1
0
Entering edit mode
15 months ago
slin023 • 0

Hello I submitted my script in Slurm to process Salmon and Trimmomatic. I checked the Salmon and Trimmomatic version, the script should be all right, but I still ran into error messages when I checked the tail log. Are those addressed something wrong with the Salmon in slurm?

$ tail log

Unable to access jarfile trimmomatic
salmon: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by salmon)
salmon: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /home/applications/spack/applications/gcc-8.2.0/intel-tbb-2019-vfqbzt4vtydsvty66tg7azlsjtfaon6v/lib/libtbbmalloc_debug.so.2)
salmon: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /home/applications/spack/applications/gcc-8.2.0/intel-tbb-2019-vfqbzt4vtydsvty66tg7azlsjtfaon6v/lib/libtbb_debug.so.2)
salmon: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /home/applications/spack/applications/gcc-4.8.5/gcc-8.2.0-sxbf4jq6ghmoybsjlpqz2dm2qbbxzfyn/lib64/libgomp.so.1)
salmon: /lib64/libc.so.6: version `GLIBC_2.17' not found (required by /home/applications/spack/applications/gcc-4.8.5/gcc-8.2.0-sxbf4jq6ghmoybsjlpqz2dm2qbbxzfyn/lib64/libgomp.so.1)
salmon: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /home/applications/spack/applications/gcc-4.8.5/gcc-8.2.0-sxbf4jq6ghmoybsjlpqz2dm2qbbxzfyn/lib64/libstdc++.so.6)
salmon: /lib64/libc.so.6: version `GLIBC_2.16' not found (required by /home/applications/spack/applications/gcc-4.8.5/gcc-8.2.0-sxbf4jq6ghmoybsjlpqz2dm2qbbxzfyn/lib64/libstdc++.so.6)
salmon: /lib64/libc.so.6: version `GLIBC_2.17' not found (required by /home/applications/spack/applications/gcc-4.8.5/gcc-8.2.0-sxbf4jq6ghmoybsjlpqz2dm2qbbxzfyn/lib64/libstdc++.so.6)
salmon: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /home/applications/spack/applications/gcc-4.8.5/gcc-8.2.0-sxbf4jq6ghmoybsjlpqz2dm2qbbxzfyn/lib64/libgcc_s.so.1)`
RNA-Seq • 343 views
ADD COMMENT
2
Entering edit mode
15 months ago
Rob 4.9k

It looks like you have an inconsistent set of modules loaded on the nodes where younare running? Can you run the software successfully from the submit node? If so, then you need to replicate the loased modules and paths in your job script. It's usually a bit more pain to get thimgs working across cluster nodes, but this is why most clusters provide module aystems to ensure uniform environments for running software.

ADD COMMENT

Login before adding your answer.

Traffic: 1728 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6