can't run Aracne -- Java error
1
0
Entering edit mode
23 months ago
rioualen ▴ 610

Hello, I'm trying to run Aracne in order to generate network data from expression data. I can't seem to run the program, despite trying different versions:

$ java -Xmx5G -jar Aracne.jar -e matrix.txt  -o outputFolder --tfs tfs.txt --pvalue 1E-8 --seed 1 -–calculateThreshold
Exception in thread "main" java.lang.NoClassDefFoundError: jargs/gnu/CmdLineParser$OptionException
  at java.base/java.lang.Class.forName0(Native Method)
  at java.base/java.lang.Class.forName(Class.java:398)
  at org.eclipse.jdt.internal.jarinjarloader.JarRsrcLoader.main(JarRsrcLoader.java:56)
Caused by: java.lang.ClassNotFoundException: jargs.gnu.CmdLineParser$OptionException
  at java.base/java.net.URLClassLoader.findClass(URLClassLoader.java:471)
  at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:588)
  at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:521)
  ... 3 more
  

I'm on macOS Mojave and openjdk 11.0.2

Any help will be greatly appreciated!

aracne RNA-Seq network • 1.2k views
ADD COMMENT
0
Entering edit mode

The macOS download seems to be an executable. Try the following steps:

  1. chmod u+x <macos_download_file>.macosx
  2. bash <macos_download_file>.macosx

macOS might restrict the script because it is from an "unknown source" If it does that, follow these steps: https://www.macworld.co.uk/how-to/mac-software/mac-app-unidentified-developer-3669596/ (you should see the "Open Anyway" option)

ADD REPLY
0
Entering edit mode

The bash command gets me a aracne2.macosx: aracne2.macosx: cannot execute binary file error. And when trying to open outside of the terminal macos does not know which application to execute it with

ADD REPLY
0
Entering edit mode

Ah, it's not an installer. Try running it directly from the shell.

/path/to/aracne2.macosx
ADD REPLY
0
Entering edit mode

I get that: Cannot find file "usage.txt"! Please make sure it is in the current working directory.

ADD REPLY
0
Entering edit mode

Aracne-AP is written for Java8, which back then (2015) was the standard!

ADD REPLY
3
Entering edit mode
22 months ago
rioualen ▴ 610

I tried running Aracne (sourceforge version) on my old laptop and it worked just fine (Ubuntu 16.04 + openjdk 1.8.92).

So in my macbook I created a conda environment, installed an old Java version in there (opendjdk 8.0.192) and Aracne is running fine.

ADD COMMENT
1
Entering edit mode

Thank you for following up. Please accept your answer so the question is marked as solved.

ADD REPLY

Login before adding your answer.

Traffic: 1806 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6