Question: Error in npm installation and start.
0
gravatar for Dineshkumar K
5 weeks ago by
Kasaragod, Kerala, India
Dineshkumar K40 wrote:

I have done pan genome analysis in panX [https://github.com/neherlab/pan-genome-analysis] and further tried to view the results in panX-pan-genome-visualization [https://github.com/neherlab/pan-genome-visualization]. I followed the instruction mentioned in the panX-visualization manual. As part of the process, I tried to install npm and end up with the following error,

npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.3 (node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.3: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.13 (node_modules/glob-watcher/node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.13: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.13 (node_modules/watchpack-chokidar2/node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.13: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.13 (node_modules/webpack-dev-server/node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.13: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
audited 984 packages in 7.99s
23 packages are looking for funding
  run `npm fund` for details
found 8 vulnerabilities (4 low, 2 moderate, 1 high, 1 critical)
  run `npm audit fix` to fix them, or `npm audit` for details

To resolve this error, I upgraded my old/default nodejs and nvm into nodejs v14.8.0 and nvm v14.4.0. I also tried to audit fix the vulnerabilities, got the following warnings,

npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.3 (node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.3: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.13 (node_modules/watchpack-chokidar2/node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.13: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.13 (node_modules/webpack-dev-server/node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.13: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.13 (node_modules/glob-watcher/node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.13: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
up to date in 6.786s
23 packages are looking for funding
  run `npm fund` for details
fixed 0 of 8 vulnerabilities in 984 scanned packages
  8 vulnerabilities required manual review and could not be updated

Having done these, I ran npm start in the concerned folder and obtained error as follows,

> panX-visualization@1.5.0 start /home/dinesh/Downloads/pan-genome-analysis-master/pan-genome-visualization
> node ./bin/www
/home/dinesh/Downloads/pan-genome-analysis-master/pan-genome-visualization/webpack.config.dev.js:25
    new webpack.NoErrorsPlugin()
   ^
TypeError: webpack.NoErrorsPlugin is not a constructor
    at Object.<anonymous> (/home/dinesh/Downloads/pan-genome-analysis-master/pan-genome-visualization/webpack.config.dev.js:25:5)
    at Module._compile (internal/modules/cjs/loader.js:1200:30)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:1220:10)
    at Module.load (internal/modules/cjs/loader.js:1049:32)
    at Function.Module._load (internal/modules/cjs/loader.js:937:14)
    at Module.require (internal/modules/cjs/loader.js:1089:19)
    at require (internal/modules/cjs/helpers.js:73:18)
    at Object.<anonymous> (/home/dinesh/Downloads/pan-genome-analysis-master/pan-genome-visualization/app.js:14:21)
    at Module._compile (internal/modules/cjs/loader.js:1200:30)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:1220:10)
npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! panX-visualization@1.5.0 start: `node ./bin/www`
npm ERR! Exit status 1
npm ERR! 
npm ERR! Failed at the panX-visualization@1.5.0 start script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.
npm ERR! A complete log of this run can be found in:
npm ERR!     /home/dinesh/.npm/_logs/2020-08-13T08_10_29_719Z-debug.log

In order to fix this, I googled about the error and followed various suggestion mentioned in various forums, However none of those suggestion served my purpose. Therefore, please help me to resolve this issue.

My OS is 64 bit Desktop-ubuntu 18.04

Thanks in advance.

bash R linux python software error • 178 views
ADD COMMENTlink modified 5 weeks ago by h.mon31k • written 5 weeks ago by Dineshkumar K40

I am far, very far, from being an expert in npm and nodejs. Having said that:

You may try to install the package again, but skipping the audit fix step. You will be running potentially unsafe software, but it may run.

Did you try using LTS (12.18.3) nodejs, instead of current?

The two first message blocks are just warnings, because the package fsevents is specific for MacOsX.

ADD REPLYlink written 5 weeks ago by h.mon31k

Thank you @h.mon, I would try the same and let you know.

ADD REPLYlink written 5 weeks ago by Dineshkumar K40
2
gravatar for h.mon
5 weeks ago by
h.mon31k
Brazil
h.mon31k wrote:

I just installed and ran using nodejs 12.18.3 and npm 6.14.6.

At first, I didn't do the npm audit fix step, even though npm warned about a plethora of vulnerabilities:

found 186 vulnerabilities (161 low, 9 moderate, 15 high, 1 critical)

After running pan-genome-visualization for a first time, I ran npm audit fix, it fixed a bunch of vulnerabilities, but not all, as there are fixes that involve breaking changes. I could run pan-genome-visualization again. Both times I ran pan-genome-visualization with npm start, there was a warning that points why you can't run with nodejs 14.8.0 and nvm 14.4.0:

WARNING in webpack: Using NoErrorsPlugin is deprecated.

Probably what was warning in LTS became an error in the current version. Downgrade nodejs and npm and you will likely succeed in running pan-genome-visualization.

ADD COMMENTlink written 5 weeks ago by h.mon31k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 1101 users visited in the last hour