Question: Doing blastn remote db, getting error
0
gravatar for lbio75
27 days ago by
lbio750
lbio750 wrote:

Hi,

I am trying to use blastn and connecting the db remotely using the below, but, getting an error.

$ blastn -db nr -query file.fasta -out blast_output.out -remote

Above command is giving me the error “[SOCK::gethostbyaddr] Got "localhost" for local host address”. Can you please let me know if I need to setup any configuration.

blastn remote • 113 views
ADD COMMENTlink modified 25 days ago • written 27 days ago by lbio750

Are you trying to run this from a system that is a) not directly connected to internet? b) is behind a proxy/firewall?

ADD REPLYlink written 27 days ago by genomax92k

No, it is not behind any firewall. Just connecting from home network. Is there any configuration that needed to be added to connect remote?

ADD REPLYlink written 25 days ago by lbio750

No configuration should be needed. Are you using a router at home? Try connecting to internet directly and see if that works. If that works then local network configuration must be causing this (how network addresses are translated etc).

ADD REPLYlink modified 25 days ago • written 25 days ago by genomax92k

Hi, tried that option too.. same issue.

ADD REPLYlink written 20 days ago by lbio750

Are you able to try and use a different computer somewhere other than you home?

ADD REPLYlink written 20 days ago by genomax92k

Hi, yes, tried on home laptop / home network, and office laptop/office network too..

ADD REPLYlink written 19 days ago by lbio750

Hi, it seems that is only warning, and I felt it was not processing. I tried with a smaller file and it worked even though it was giving the above warning without changing anything on the command. Thanks for your replies.

ADD REPLYlink written 17 days ago by lbio750
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 1272 users visited in the last hour