vcftools not outputting any file, and not giving any error message
1
0
Entering edit mode
11 months ago
dec986 ▴ 300

Hello,

I'm running this vcftools command on a 148 GB vcf.gz flie:

nohup vcftools --exclude-positions X.bed --gzvcf merged.vcf.gz --out merged.noX &

the bed file was made with vcf2bed.

however, even after about 15 minutes, there is no output except a log file, and the program keeps running.

the log file shows:

VCFtools - 0.1.17
(C) Adam Auton and Anthony Marcketta 2009

Parameters as interpreted:
    --gzvcf merged.vcf.gz
    --exclude-positions X.bed
    --out merged.noX

Using zlib version: 1.2.7
Warning: Expected at least 2 parts in FORMAT entry: ID=GP,Number=3,Type=Float,Description="Estimated Posterior Probabilities for Genotypes 0/0, 0/1 and 1/1">
After filtering, kept 2501 out of 2501 Individuals

Did I do anything wrong? Why isn't this making any output file? Or should I just wait?

Even if I re-direct output to STDOUT, I get nothing.

I'm anxious, because this could take a long time to run, and I don't want to waste hours of time for some minor mistake.

vcftools • 459 views
ADD COMMENT
0
Entering edit mode
11 months ago
dec986 ▴ 300

the problem was that vcftools needs recode to have output at all.

vcftools --exclude-positions X.bed --gzvcf merged.vcf.gz --out merged.noX --recode

ADD COMMENT

Login before adding your answer.

Traffic: 1904 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6