Command not found after pip install spliceai
0
0
Entering edit mode
13 months ago

Hi everyone, I used pip install to install spliceai, but then when I try to use commands like spliceai at the command line it says command not found. I believe I need to move something to my "PATH", but I am pretty unfamiliar with this and am not sure how it works (also new to using pip install) so would appreciate any advice.

Thank you!

software error • 948 views
ADD COMMENT
0
Entering edit mode

I'd suggest installing via Conda

ADD REPLY
0
Entering edit mode

Hey I installed Miniconda2, but when I try to do conda install -c bioconda spliceai it says zsh: command not found: conda

ADD REPLY
0
Entering edit mode

It is possible that you need to log out and back in for the installation to work. Or try typing rehash on command line.

ADD REPLY
0
Entering edit mode

I think it said at one point that it installed successfully - I just think it isn't in my PATH or something (from what I read about online regarding this type of issue). I just don't know how to navigate my files in a way that moves the installed commands on to my PATH so that they may be executed.

ADD REPLY
0
Entering edit mode

Please copy and paste the commands you used, and the error message.

Did you (pip) install TensorFlow as well? It is a requirement, but it isn't installed automatically.

ADD REPLY
0
Entering edit mode

ianchiquier@Ians-MBP-2 % cat current_input.vcf | spliceai -R genome.fa -A grch38 > novel_output.vcf zsh: command not found: spliceai

And I just did pip install TensorFlow and still get the same error.

ADD REPLY

Login before adding your answer.

Traffic: 2703 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6