New Hg18 Genome In R
1
0
Entering edit mode
11.9 years ago
e.karasmani ▴ 140

Dear All,

Good morning! I would like to ask you a question......

I am doing a Hi-C experiment in a biological material at which at a specific position i have placed a 1.5 KB insertion.

So in the analysis of that experiment ( I am using different R packages such as IRanges) I need to load initially the library(BSgenome.Hsapiens.UCSC.hg18).

But in my experiment the normal hg18 (as you understand) is not the correct one because my material has this 1.5 KB insertion.

So I think that I have to make a new version of the Hg18 to load with this insertion at the specific position

How do you think I can do that? How can I make a new Hg18 library in order to load it?

I will wait for your answer

Best regards Eleni

r genome sequence • 2.3k views
ADD COMMENT
2
Entering edit mode

I don't really understand your question. If your sequence has an insertion, just add the insertion, and run your analyses on the new sequence.

What type of analyses will you be running? BLAST? We might be able to help you more if you give us more details on what exactly you are trying to run.

ADD REPLY
1
Entering edit mode

Yes, please improve this question. What are you doing in R? Using a particular package? And why do you need the whole genome if your insertion is at only one specific location?

ADD REPLY
0
Entering edit mode

Sorry I have done it!

ADD REPLY
1
Entering edit mode
11.9 years ago

If you have your own pipelines using the BSgenome 'hg18' package and IRanges, and you do not want to change your scripts, then you might need your custom BSgenome package. Read here how to build your own.

However, depending on the analyses you are running, it might be simpler to adapt your pipelines to run on a modified fasta file containing your insert than to build you own custom BSgenome package.

ADD COMMENT

Login before adding your answer.

Traffic: 3154 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6