Genscan Doesn'T Run
3
0
Entering edit mode
11.2 years ago
Ken ▴ 10

Hi, I am migrating things from our old server to new servers. The genscan works fine in the old server but it doesn't work in the new server. The new server is a VM with Ubuntu 12.04 server version installed. I download the genscan linux version, decoded and untar it. Somehow that when I try to run it, it gives me this error:

ggb2blastb@safs-fujin:~/apps/genscan$ ls -l
total 764
dr-xr-xr-x 2 ggb2blastb ggb2blastb   4096 Feb  4 14:10 ./
drwxrwxr-x 6 ggb2blastb ggb2blastb   4096 Feb  4 14:11 ../
-r-xr--r-- 1 ggb2blastb ggb2blastb 219056 Feb  4 14:10 Arabidopsis.smat*
-r-xr-xr-x 1 ggb2blastb ggb2blastb 126365 Feb  4 14:10 genscan*
-r-xr--r-- 1 ggb2blastb ggb2blastb 219050 Feb  4 14:10 HumanIso.smat*
-r-xr--r-- 1 ggb2blastb ggb2blastb   6622 Feb  4 14:10 HUMRASH*
-r-xr--r-- 1 ggb2blastb ggb2blastb   6344 Feb  4 14:10 HUMRASH.ps*
-r-xr--r-- 1 ggb2blastb ggb2blastb    849 Feb  4 14:10 HUMRASH.sample*
-r-xr--r-- 1 ggb2blastb ggb2blastb 155735 Feb  4 14:10 Maize.smat*
-r-xr--r-- 1 ggb2blastb ggb2blastb  24465 Feb  4 14:10 README*

ggb2blastb@safs-fujin:~/apps/genscan$ ./genscan
bash: ./genscan: No such file or directory

Does anyone have any idea how I can fix it? Thanks in advance.

UPDATE:

I copied the executable file 'genscan' to other machines and test it. Another Ubuntu VM also shows the same error even though the VM is in a different physical system located in the other site. And it only works properly in other none-VM based system. Any help will be appreciated!!

genscan • 4.0k views
ADD COMMENT
0
Entering edit mode

Do those file names really end with *?

ADD REPLY
0
Entering edit mode

No, the asterisk (*) is just the ls -l shows for the executable files. When just ls, no * is shown.

ADD REPLY
0
Entering edit mode

Odd, I don't see that with ls -l. Must be some bash profile thing specific to your machine.

ADD REPLY
1
Entering edit mode

you would get it with ls -lF - this indicates that the OP must have some other systems settings applied

ADD REPLY
2
Entering edit mode
11.2 years ago
Neilfws 49k

I have performed the same steps as you, except that my Ubuntu 12.04 is not running in a VM. In my case, the command:

./genscan

prints out a usage message, as expected.

If you are running the command from the same directory as the binary and the executable flags are set, you simply should not be seeing that error message.

Not a solution to the problem but: I note that genscan is rather old software (1997). There are newer and one imagines, better gene prediction tools available.

ADD COMMENT
0
Entering edit mode

I agree that we should use a newer gene prediction tools. What your prefer one? In my case, as one of our previously developed application used genscan so I have to get genscan working just for the application. Thanks for your help.

ADD REPLY
0
Entering edit mode

I like glimmer but even that is some years old now; there's sure to be something more recent.

ADD REPLY
1
Entering edit mode
11.2 years ago
Ken ▴ 10

Thanks Neilfws for looking into it. After looked into the binary file of genscan, noticed they hard-coded 3 specific libraries which our system is missing. They are:
/lib/libc.so.6
/lib/libm.so.6
/lib/ld-linux.so.2
I copy those 3 libraries from the old OS to the new machine. genscan works now.

ADD COMMENT
0
Entering edit mode

The same problem came to me either, can you please copy me the 3 specific libraries?

ADD REPLY
0
Entering edit mode

how did you find the 3 libraries your OS have not? can you teach me a litter?

ADD REPLY
0
Entering edit mode
9.2 years ago

After an hour analysis, I have fixed the issue by installing libc.

sudo apt-get install libc6-amd64

Might be helpful for some one...

Issue :

genscan
-bash: /usr/bin/genscan: No such file or directory

After Fix:

genscan

usage: genscan parfname seqfname [-v] [-cds] [-subopt cutoff] [-ps psfname scale]

       parfname : full pathname of parameter file
                  (for appropriate organism)
ADD COMMENT

Login before adding your answer.

Traffic: 2714 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6