Question: Installing Ggbio
0
gravatar for simonconti
5.6 years ago by
simonconti0
simonconti0 wrote:

bioconductor used to install ggbio without issue. It seems as though since the installation of R 3.0.0 this no longer works. It gives the following error messages.

** preparing package for lazy loading
Error : package 'bitops' was built before R 3.0.0: please re-install it
ERROR: lazy loading failed for package 'Rsamtools'
* removing '..........x86_64-pc-linux-gnu-library/3.0/Rsamtools'
ERROR: dependency 'RSQLite' is not available for package 'AnnotationDbi'
* removing '...........x86_64-pc-linux-gnu-library/3.0/AnnotationDbi'
ERROR: dependency 'RCurl' is not available for package 'biomaRt'
* removing '...........x86_64-pc-linux-gnu-library/3.0/biomaRt'
ERROR: dependency 'munsell' is not available for package 'scales'
* removing '...........x86_64-pc-linux-gnu-library/3.0/scales'
ERROR: dependencies 'RCurl', 'Rsamtools' are not available for package 'rtracklayer'
* removing '............x86_64-pc-linux-gnu-library/3.0/rtracklayer'
ERROR: dependency 'scales' is not available for package 'ggplot2'
* removing '..............x86_64-pc-linux-gnu-library/3.0/ggplot2'
ERROR: dependencies 'AnnotationDbi', 'RSQLite', 'rtracklayer', 'biomaRt', 'RCurl' are not available for package 'GenomicFeatures'
* removing '............x86_64-pc-linux-gnu-library/3.0/GenomicFeatures'
ERROR: dependencies 'scales', 'Rsamtools', 'GenomicFeatures' are not available for package 'biovizBase'
* removing '..............x86_64-pc-linux-gnu-library/3.0/biovizBase'
ERROR: dependencies 'Rsamtools', 'AnnotationDbi', 'GenomicFeatures' are not available for package 'VariantAnnotation'
* removing '..............x86_64-pc-linux-gnu-library/3.0/VariantAnnotation'
ERROR: dependencies 'ggplot2', 'biovizBase', 'GenomicFeatures', 'Rsamtools', 'scales', 'VariantAnnotation', 'rtracklayer' are not available for package 'ggbio'
* removing '...............x86_64-pc-linux-gnu-library/3.0/ggbio'

The downloaded source packages are in
    '/tmp/RtmphFekSZ/downloaded_packages'
There were 14 warnings (use warnings() to see them)

Thanks!

R bioconductor • 3.3k views
ADD COMMENTlink modified 5.6 years ago • written 5.6 years ago by simonconti0
4
gravatar for Sean Davis
5.6 years ago by
Sean Davis25k
National Institutes of Health, Bethesda, MD
Sean Davis25k wrote:

It looks like you have a mix of packages built for different R versions and have some packages that do not have their dependencies installed correctly. I have seen this when folks have tried to install a new version of R without reinstalling all packages or have been installing packages "by hand" rather than using biocLite(). I would encourage you to use biocLite() as suggested on the Bioconductor website. You may want to start over from scratch (remove your R packages and reinstall).

ADD COMMENTlink written 5.6 years ago by Sean Davis25k

I agree it looks like a package version problem. Before reinstalling however make sure to use the argument "checkbuild=T" when upgrading your packages.

ADD REPLYlink written 5.6 years ago by Alastair Kerr5.2k
0
gravatar for simonconti
5.6 years ago by
simonconti0
simonconti0 wrote:

I have been using biocLite to install these packages. It is my university's public server actually...so every time I log in i'm starting from scratch and have to reinstall ggbio, BSgenome, methylkit...etc..

ADD COMMENTlink written 5.6 years ago by simonconti0
2

This should have been a comment to Sean Davis's answer, not your own answer. There seems to be a lot of things wrong with your install -- but you can see that it starts with the "bitops" package, as you are loading one that was built on a version of R that is lower than 3.0. Reinstall that package, load it, and see if it works .. .then continue from there.

ADD REPLYlink written 5.6 years ago by Steve Lianoglou4.9k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 1410 users visited in the last hour