Question: Problem Compiling Tophat: Boostlib >= 1.38.0 Not Found
0
gravatar for abhi4.amity
5.7 years ago by
abhi4.amity0 wrote:
[root@fatnode tophat-2.0.9]# ./configure --prefix=/usr/local/bin/
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking for gawk... (cached) gawk
checking for g++... g++
checking for C++ compiler default output file name... a.out
checking whether the C++ compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking for style of include used by make... GNU
checking dependency style of g++... gcc3
checking for gcc... gcc
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking dependency style of gcc... gcc3
checking whether make sets $(MAKE)... (cached) yes
checking for ranlib... ranlib
checking for a BSD-compatible install... /usr/bin/install -c
checking for a Python interpreter with version >= 2.4... python
checking for python... /usr/bin/python
checking for python version... 2.6
checking for python platform... linux2
checking for python script directory... ${prefix}/lib/python2.6/site-packages
checking for python extension module directory... ${exec_prefix}/lib64/python2.6/site-packages
checking for boostlib >= 1.38.0... configure: error: We could not detect the boost libraries (version 1.38 or higher). If you have a staged boost library (still not    installed) please specify $BOOST_ROOT in your environment and do not give a PATH to --with-boost option.  If you are sure you have boost installed, then check your version number looking in <boost version.hpp="">. See http://randspringer.de/boost for more documentation.
tophat • 3.5k views
ADD COMMENTlink modified 5.7 years ago by Devon Ryan91k • written 5.7 years ago by abhi4.amity0
3

I've reformatted your question so that the output from ./configure displays properly (I also changed your title and tags such that people can better gauge what your question is actually about). The error at the bottom is pretty explicit (made more so by my change to your title). Have you read it and done what it says?

ADD REPLYlink modified 5.7 years ago • written 5.7 years ago by Devon Ryan91k

boostlib >= 1.38.0... configure: error: We could not detect the boost libraries

first use this command to know if it is installed or not and what version exist if installed

dpkg -s libboost-dev | grep 'Version'

based on what you will find we shall proceed either to install it or to install suitable version ok?

another solution is to use a precompiled version if you use linux 68 follow this link tophat-2.0.9.Linux_x86_64.tar.gz

ADD REPLYlink modified 5.7 years ago • written 5.7 years ago by Medhat8.4k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 1564 users visited in the last hour