Question: Multiple Issues With 1.4.4 Breakdancer Compile
0
gravatar for dieabonnements
3.9 years ago by
dieabonnements0 wrote:

I am trying to get the latest version of breakDancer running on our local hardware When using the instructions in Install.md I am encountering as below. First I receive an error from the cmake step where it appears the test for breakDancer-max is missing somehow If I ignore this error and proceed with the make there are problems with boost (it appears as though it is looking in the wrong place for bootstrap.sh) I have had good luck for the most part with the pre-compiled breakdancer 1.1.2 off http://gmt.genome.wustl.edu/breakdancer/current/ however I have never been able to get the -o option to work so was hoping that this would be resolved in the latest version. Any help is appreciated (I have spent hours trying to get this installed and am a bit at wits end)

/home/tools/CNV/genome/pem/Breakdancer> git clone --recursive https://github.com/genome/breakdancer.git Initialized empty Git repository in /home/tools/CNV/genome/pem/Breakdancer/breakdancer/.git/ remote: Counting objects: 3520, done. remote: Compressing objects: 100% (1485/1485), done. remote: Total 3520 (delta 1578), reused 3520 (delta 1578) Receiving objects: 100% (3520/3520), 8.38 MiB | 1.34 MiB/s, done. Resolving deltas: 100% (1578/1578), done. Submodule 'build-common' (git://github.com/genome/build-common.git) registered for path 'build-common' Initialized empty Git repository in /home/tools/CNV/genome/pem/Breakdancer/breakdancer/build-common/.git/ remote: Reusing existing pack: 175, done. remote: Total 175 (delta 0), reused 0 (delta 0) Receiving objects: 100% (175/175), 1.98 MiB | 94 KiB/s, done. Resolving deltas: 100% (63/63), done. Submodule path 'build-common': checked out '28f2df445cddd7c09c09d79d3d30bddd458da223' export SAMTOOLS_ROOT=/home/tools/CNV/genome/pem/Breakdancer/samtools-0.1.19/ /home/tools/CNV/genome/pem/Breakdancer> cd breakdancer /home/tools/CNV/genome/pem/Breakdancer/breakdancer> mkdir build /home/tools/CNV/genome/pem/Breakdancer/breakdancer> cd build /home/tools/CNV/genome/pem/Breakdancer/breakdancer/build> cmake .. -DCMAKE_BUILD_TYPE=release -DCMAKE_INSTALL_PREFIX=/usr/local -- The C compiler identification is unknown -- The CXX compiler identification is unknown -- Check for working C compiler: /usr/bin/gcc -- Check for working C compiler: /usr/bin/gcc -- works -- Detecting C compiler ABI info -- Detecting C compiler ABI info - done -- Check for working CXX compiler: /usr/bin/c++ -- Check for working CXX compiler: /usr/bin/c++ -- works -- Detecting CXX compiler ABI info -- Detecting CXX compiler ABI info - done Score floating point type: double -- Looking for include files CMAKE_HAVE_PTHREAD_H -- Looking for include files CMAKE_HAVE_PTHREAD_H - found -- Looking for pthread_create in pthreads -- Looking for pthread_create in pthreads - not found -- Looking for pthread_create in pthread -- Looking for pthread_create in pthread - found -- Found Threads: TRUE Extracting boost from /home/tools/CNV/genome/pem/Breakdancer/breakdancer/vendor/boost-1.54-breakdancer.tar.gz Boost build log can be found at /home/tools/CNV/genome/pem/Breakdancer/breakdancer/build/vendor/boost-src/build.log -- Configuring done CMake Error at build-common/cmake/TestHelper.cmake:65 (add_test): Error evaluating generator expression:

$<TARGET_FILE:breakdancer-max>

No target "breakdancer-max" Call Stack (most recent call first): integration-test/CMakeLists.txt:3 (def_integration_test)

-- Generating done -- Build files have been written to: /home/tools/CNV/genome/pem/Breakdancer/breakdancer/build

/home/tools/CNV/genome/pem/Breakdancer/breakdancer/build> make Scanning dependencies of target boost-1.54 [-12%] Creating directories for 'boost-1.54' [-12%] Performing download step (verify and extract) for 'boost-1.54' -- verifying file... file='/home/tools/CNV/genome/pem/Breakdancer/breakdancer/vendor/boost-1.54-breakdancer.tar.gz' -- verifying file... warning: did not verify file - no URL_MD5 checksum argument? corrupt file? -- extracting... src='/home/tools/CNV/genome/pem/Breakdancer/breakdancer/vendor/boost-1.54-breakdancer.tar.gz' dst='/home/tools/CNV/genome/pem/Breakdancer/breakdancer/build/vendor/boost-src' -- extracting... [tar xfz] -- extracting... [analysis] -- extracting... [rename] -- extracting... [clean up] -- extracting... done [-12%] No patch step for 'boost-1.54' [-12%] No update step for 'boost-1.54' [-12%] Performing configure step for 'boost-1.54' /bin/sh: ./bootstrap.sh: No such file or directory make[2]: * [vendor/src/boost-1.54-stamp/boost-1.54-configure] Error 127 make[1]: [CMakeFiles/boost-1.54.dir/all] Error 2 make: ** [all] Error 2

breakdancer error • 1.9k views
ADD COMMENTlink modified 3.9 years ago by ernfrid380 • written 3.9 years ago by dieabonnements0

Can you also state what your operating system and cmake version are?

ADD REPLYlink written 3.9 years ago by ernfrid380

cmake version 2.8.4 CentOS release 6.3

ADD REPLYlink written 3.9 years ago by dieabonnements0
0
gravatar for ernfrid
3.9 years ago by
ernfrid380
Saint Louis
ernfrid380 wrote:

I was able to get this to compile successfully on a CentOS 6.3 Virtual Machine and could not replicate your error message about the Cmake generator statement.

I have installed the following on a fresh image:

yum groupinstall 'Development Tools'
yum install zlib-devel ncurses-devel

I also used the rpm for Cmake 2.8.4 located here: ftp://rpmfind.net/linux/atrpms/sl6-i386/atrpms/testing/cmake-2.8.4-1.el6.i686.rpm

I would try 3 things at this point.

  1. Don't export SAMTOOLS_ROOT, this is no longer needed. The INSTALL.md file is slightly out of date.
  2. Check that you haven't filled your disk up (on the off chance this has happened).
  3. Reinstall Cmake 2.8.0 or higher and see if that fixes the problem.
ADD COMMENTlink modified 3.9 years ago • written 3.9 years ago by ernfrid380
  1. Not exporting SAMTOOLS_ROOT didn't have any effect
  2. Disk space is ok
  3. Will have to wait on sys admin for such changes and will get back to you

As I mentioned in my initial post my impetus for attempting the newest version is to see if the -o (work on per chromosome basis to speed things up) is working properly. Has this been tested and proven to be working in Breakdancer 1.3.6? It doesn't appear to be working in 1.1.2 (even after linking with samtools 0.1.1.6)

ADD REPLYlink modified 3.9 years ago • written 3.9 years ago by dieabonnements0

Yes. We've routinely been running Breakdancer 1.3.6 with the -o option.

ADD REPLYlink written 3.9 years ago by ernfrid380

Excellent. Looking forward to using this feature. Are you aware of any additional opportunities for parallelization beyond using -o?

ADD REPLYlink written 3.9 years ago by dieabonnements0

None that I know of. Were you able to get 1.4.4 to work with your sysadmin's help?

ADD REPLYlink written 3.8 years ago by ernfrid380
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 1309 users visited in the last hour