How install DESeq2, gplots, RColorBrewer in R?
1
0
Entering edit mode
3 months ago

I want to install (DESeq2), it gives me this message. Can you guide me?

Is there any tutorial to train how I use R for drawing heatmap, pathways...? Thanks

 if (!requireNamespace("BiocManager", quietly = TRUE))
+     install.packages("BiocManager")
> 
> BiocManager::install("DESeq2")
Bioconductor version 3.13 (BiocManager 1.30.16), R 4.1.0 (2021-05-18)
Installation paths not writeable, unable to update packages
  path: C:/Program Files/R/R-4.1.0/library
  packages:
    Matrix, mgcv
Old packages: 'isoband'
Update all/some/none? [a/s/n]: 
analysis RNA-Seq • 421 views
ADD COMMENT
0
Entering edit mode

Have you already installed the lastest version of Bioconductor? Perhaps, the problem is there.

ADD REPLY
2
Entering edit mode
3 months ago

Have you searched at all? There are dozens of tutorials and vignettes that show how to use these packages. You can ignore this warning (by typing "n" then pressing enter), it's just warning you that you have a few old packages that couldn't be updated.

I recommend doing some reading and trying to follow some of the tutorials available. There are many examples of code that you can mostly copy and paste to get a generic analysis and figures, but you should really try to understand the commands you're running and why they are necessary. It can be a frustratingly slow process to start, but it'll benefit your growth as a scientist greatly in the long run.

ADD COMMENT
0
Entering edit mode

Yes, I found the tutorial. thanks. I want to install a bioconductor. Please see this message? Second question, the program can not read my file " alignment". Error in file(file, "rt") : cannot open the connection this file is on my desktop. When I add the address C/ Desktop.... / Alingment.csv. I received another error. Please guide.

Bioconductor version 3.13 (BiocManager 1.30.16), R 4.1.0 (2021-05-18) Installation paths not writeable, unable to update packages path: C:/Program Files/R/R-4.1.0/library packages: Matrix, mgcv Old packages: 'isoband' Update all/some/none? [a/s/n]: n Warning message: package(s) not installed when version(s) same as current; use force = TRUE to re-install: 'DESeq2'

library(DESeq2) library(gplots) library(RColorBrewer)

Read the counts from the downloaded data

speqdata <- read.csv("Allingment.txt") Error in file(file, "rt") : cannot open the connection In addition: Warning message: In file(file, "rt") : cannot open file 'Allingment.txt': No such file or directory

ADD REPLY
0
Entering edit mode

Do not ask a second question in the same thread. Please stick to one topic.

ADD REPLY
0
Entering edit mode

Thanks jared.andrews07!

ADD REPLY
0
Entering edit mode

Don't add answers unless you're answering the top level question. Use Add Comment or Add Reply instead as appropriate. I've moved your post to a comment this time.

ADD REPLY

Login before adding your answer.

Traffic: 2741 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6