smartPCA: problem with .evec file
0
0
Entering edit mode
12 months ago
Alexandra ▴ 10

Hi all! I'm having problems with .evec file when running smartPCA. This file doesn't consider all the individuals that I introduced in .ped file (529 individuals).

Anyone knows what the problem might be? The command that I used was: ./smartpca -p Patag_sud_maf_ld.par > Patag_sud_maf_ld.out

The .par file contains:

genotypename: Patag_sud_maf_ld.ped snpname: Patag_sud_maf_ld.map indivname: Patag_sud_maf_ld.ped evecoutname: Patag_sud_maf_ld.evec evaloutname: Patag_sud_maf_ld.eval numoutlieriter: 0

I will apreciate your answer!

file evec smartpca • 681 views
ADD COMMENT
0
Entering edit mode

Hey alexandra - super hard to answer without having access to the files. If I were faced with this problem, I would first check that all the sample IDs match exactly across the files. I would then check that all the files are formatted correctly.

If both of those don't turn up anything useful, my third step would probably be to find which of the 529 samples are PCAed, and which of the 529 are not. Once you have lists of who didnt get included, you might be able to work backwards and figure out why they weren't... (i.e. if those not included share any common feature).

Hope that helps.

ADD REPLY
1
Entering edit mode

Thank you! But still I don't know what the problem might be. I tried what you told me, and the .evec file only consider a group of samples that belong to the same region and were taken together. Maybe is the problem in the merge of the data?

ADD REPLY
0
Entering edit mode

Yeah that sounds like it is almost certainly the problem. I am not sure exactly what you mean by "same region and taken together" but that sounds like the kind of thing that will trip the PCA algorithm up...

ADD REPLY

Login before adding your answer.

Traffic: 1359 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6