Error: mdb_env_open: Bad file descriptor
0
0
Entering edit mode
24 days ago
vasudha • 0

Hi,

I am trying to use the following command:

blastn -task blastn -db blastdb/nt/nt -query genome_bin.1.fa -out genome1.out

and I am facing the following error:

Error: mdb_env_open: Bad file descriptor

I am not able to find anything regarding the same. It will be really helpful if anyone can guide me through this error. Thanks in advance.

blastn blast • 577 views
ADD COMMENT
0
Entering edit mode

Can you check you have the correct permission to read and/or write to all files you use in your cmdline?

ADD REPLY
0
Entering edit mode

Yes I just checked and I do have read and write permissions to all the files.

Also, I formed the database manually because

update_blastdb.pl --passive --decompress nt
`

was throwing an error. Therefore I downloaded all the files and decompressed them manually. I have all the .nhd, .nhi, .nhr, .nin, .nnd, .nni, .nog, .nsq files.

And one more thing, my database and blast+ tool is located in the hard disk.

ADD REPLY
0
Entering edit mode

what was the error you got from the update_blastdb script ?

you should also have a file called nt.nal , do you have that one too?

are the paths OK? so your blast DB is located in a subfolder where you run this command? (or should it be /blastdb/nt/nt , as starting from a root path?)

your query file is a correct fasta file?

ADD REPLY
0
Entering edit mode

yes I do have nt.nal available in the folder. All the paths are defined correctly as you mentioned.

my fasta file contains multiple sequences, following format:

>header1 ACTG...
>header2 ATGGC...
ADD REPLY
0
Entering edit mode

is this the format of your fasta file as it is in the file?

it should actually be like this:

>header1 
ACTG...
>header2 
ATGGC...

(not sure this is the cause of the issue though)

ADD REPLY
0
Entering edit mode

yaah..i meant this format only... just a typo..

and when I use : bin/update_blastdb.pl --passive --decompress nt

I get

Connected to NCBI Downloading nt (44 volumes) ...

Decompressing nt.00.tar.gz ...Could not write data to '/blastdb/nt/nt.ndb' at /bin/update_blastdb.pl line 496.

Failed to decompress nt.00.tar.gz (Could not write data to '/blastdb/nt/nt.ndb'), please do so manually.

This is same for all 44 files.

ADD REPLY
0
Entering edit mode

sounds like you don't have write permissions in that specific folder? or there is no space left ?

ADD REPLY
0
Entering edit mode

I checked, all the files have write permissions and there's memory as well. Do line 496 in update_blastdb.pl refers to anything related to this?

Though now I have decompressed the files manually. I am just facing the above mentioned issue.

ADD REPLY
0
Entering edit mode

Can ncbi blast+ and the database be at different paths?

ADD REPLY
0
Entering edit mode

yes , absolutely. Just add the correct paths to either of them then (or add them to your $PATH env variable)

ADD REPLY
0
Entering edit mode

okay. I am defining all the paths correctly.

ADD REPLY

Login before adding your answer.

Traffic: 1619 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6