RNASeq Salmon tximport error
0
0
Entering edit mode
5 weeks ago
Claire • 0

Hi everyone

I am new to this. I am trying to run do egdeR after Salmon quantification and using tximport to move from transcript level to gene level. My code is:

 names(files) <- paste0("sample", 1:4) 
 print(names)
 file.exists(files)
 tr2gene <- read.csv("tx2gene.csv") 
 txi <- tximport(files, type ="salmon",txIn = TRUE, tx2gene = tr2gene)

I got this error:

Error in tximport(files, type = "salmon", txIn = TRUE, tx2gene = tr2gene) : 
  unused argument (tx2gene = tr2gene)

I tried txOUT = False same error.

I checked tr2gene, it is read correctly and exists. Also checked files:

>     [1] "sample1.s_1.stress.quant.sf"   "sample2.s_1.stress.quant.sf"  
>     [3] "sample3.s_1.wildtype.quant.sf" "sample4.s_1.wildtype.quant.sf"
>     function (x)  .Primitive("names")
>     [1] TRUE TRUE TRUE TRUE

Thank you

Salmon RNASeq • 389 views
ADD COMMENT
1
Entering edit mode

What version of tximport are you using? What is the output of sessionInfo()

ADD REPLY
0
Entering edit mode
tximport version is 0.0.15
> sessionInfo()
R version 3.2.2 (2015-08-14)
Platform: x86_64-pc-linux-gnu (64-bit)
Running under: Scientific Linux 7.9 (Nitrogen)

locale:
 [1] LC_CTYPE=en_GB.UTF-8       LC_NUMERIC=C              
 [3] LC_TIME=en_GB.UTF-8        LC_COLLATE=en_GB.UTF-8    
 [5] LC_MONETARY=en_GB.UTF-8    LC_MESSAGES=en_GB.UTF-8   
 [7] LC_PAPER=en_GB.UTF-8       LC_NAME=C                 
 [9] LC_ADDRESS=C               LC_TELEPHONE=C            
[11] LC_MEASUREMENT=en_GB.UTF-8 LC_IDENTIFICATION=C       

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base     

other attached packages:
[1] tximport_0.0.15

Thank you

ADD REPLY
1
Entering edit mode

This is a very, very old version of tximport. It probably doesn't work the same way as the manual suggests it does. Try updating to a more recent version.

ADD REPLY
0
Entering edit mode

Ok thanks so much. Will try this out.

ADD REPLY
0
Entering edit mode

Just in case someone comes through this error, upgrading tximport fixed it. Thank you i.sudbery !

ADD REPLY

Login before adding your answer.

Traffic: 2455 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6