Is the current R version (4.1.2) are not suitable for the packages related with TCGA
1
1
Entering edit mode
7 weeks ago
nonaddldy ▴ 10

I cannot install series of packages related with TCGA, no matter through BiocManager::install or install.packages enter image description here

enter image description here

enter image description here

TCGA R • 804 views
ADD COMMENT
0
Entering edit mode

It is very unlikely. Restart the R session and then try again. Also however I couldn't see in the posted images, sometimes a missing/outdated Linux library can be the cause. Inspect the error you may find that.

ADD REPLY
0
Entering edit mode

I tried to install the related library from the warning report: "ERROR: dependencies: ..." (Picture 2). But the outputs are still like the above.

ADD REPLY
0
Entering edit mode

There must be some initial error at the very beginning that causes this whole chain of errors. Probably some lib is missing. Is this the full error message?

ADD REPLY
0
Entering edit mode

Actually, I cannot install almost all of the library mentioned in the warning messages.

ADD REPLY
1
Entering edit mode
4 weeks ago

TCGAretriever requires r-base >=3.6,<3.7.0. I recommend using a software environment manager like conda supplemented with mamba to create an environment specifically for TCGAretriever to avoid having to downgrade your system R.

Once conda and mamba are installed and configured you can run the following command to install TCGAretriever.

mamba create -n tcgaretriever -c conda-forge -c bioconda r-tcgaretriever

It will automatically install the proper R version.

You can then activate and use the environment via conda activate tcgaretriever.

ADD COMMENT
0
Entering edit mode

Thanks a lot. I will try it.

ADD REPLY

Login before adding your answer.

Traffic: 1514 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6