error when indexing transcroptome using salmon
0
0
Entering edit mode
13 months ago
Sara ▴ 220

I have made a singularity container for the salmon v1.6.0 and I am working with centOS. I am trying to make an index file for human transcript using this command:

salmon index -t hg19_EnsenmblGenes_sequence_ensenmbl.fasta -i Ensembl_hg19_salmon_index

But I am getting this error:

Version Info: This is the most recent version of salmon.
exception : [the option '--index' is required but missing]. Exiting.

Then I tried this command:

salmon --index -t hg19_EnsenmblGenes_sequence_ensenmbl.fasta -i Ensembl_hg19_salmon_index

Then I got this error:

Version Info: This is the most recent version of salmon. salmon was invoked improperly. For usage information, try salmon --help Exiting.

Do you know how I can fix the issue?

Transcriptome salmon • 979 views
ADD COMMENT
1
Entering edit mode

Your command looks correct, and the error message is referring, somehow, to the options parser not finding the option for where to place the index -i = --index. Can you do which salmon?

Also, do you get the same thing if you use the command:

salmon index -t hg19_EnsenmblGenes_sequence_ensenmbl.fasta --index Ensembl_hg19_salmon_index
ADD REPLY
0
Entering edit mode

Rob with the which salmon command I got this:

/usr/local/bin/salmo

but the version of salmon is the latest which is: salmon v1.6.0. when I run the command you mentioned it works (still running). but I got my reference file from gencode. do I have to use this option :

--gencode

instead of -t

it is mentioned in the result of this command:

salmon index -- help
ADD REPLY
2
Entering edit mode

That is very strange, as -i and --index should be interchangeable. Nonetheless, I'm glad that --index worked. Regarding using --gencode, this is recommended if you want the output to make use of simplified transcript names (everything up to the first | in the fasta header for each transcript). If you want the full (looong) name, then you can leave off the --gencode. It will have no effect on the actual results of quantification, apart from the name used in the output files for the transcripts. Also, --gencode is a flag that one can pass in addition to the require -t option, not a replacement for -t.

ADD REPLY
0
Entering edit mode

did you try:

For usage information, try salmon --help

?

ADD REPLY
0
Entering edit mode

lieven.sterck yes I did. in the help shows the command I used. that is why I am confused! I should also mention that I used that without singularity as well and got the same error.

ADD REPLY
0
Entering edit mode

ok.

your first version should work though (with index without the -- ) .

can you run salmon index --help ?

ADD REPLY
0
Entering edit mode

lieven.sterck I did and returns a list of possible items (like when you do --help). and when I did :

salmon index --gencode gencode.v39.transcripts.fa

I got this error again:

Version Info: This is the most recent version of salmon.
exception : [the option '--index' is required but missing]. Exiting.
ADD REPLY
0
Entering edit mode

long shot, but do you have write permissions for the location where you want to write/put/create the index?

and do follow Rob 's advise and suggestions (can't get any better than direct from the developers ;) )

ADD REPLY

Login before adding your answer.

Traffic: 824 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6