Bioconductor, R, RipSeeker and RIP-seq problem
0
0
Entering edit mode
7 months ago
GiV17 ▴ 40

Hi all, I have a problem with the different version of R-RStudio and RipSeeker package. I'm working with R 4.1.2, RStudio 2021.09.1 Build 372, Bioconductor version 3.14, but for RipSeeker package is required R version "3.6" and Bioconductor version: 3.9 . see https://bioconductor.riken.jp/packages/3.9/bioc/html/RIPSeeker.html for Bioconductor 3.14 the package was not found on this server. see https://bioconductor.riken.jp/packages/3.14/bioc/html/RIPSeeker.html So I have a big problem. How Can I solve this? Thanks all

RIP-SEQ RipSeeker • 453 views
ADD COMMENT
1
Entering edit mode
ADD REPLY
0
Entering edit mode

It was deprecated in 3.11. That means you need a separate environment to install it into, with the respective R and Bioc version. Easiest is probably a conda environment, see https://anaconda.org/bioconda/bioconductor-ripseeker

Alternatively, make a Docker container. Does that make sense to you?

ADD REPLY
0
Entering edit mode

so? I work in local Windows 10 System. How can I make a Docker? Thanks

ADD REPLY
0
Entering edit mode

Actually for simplicity, I would get WSL2 running and then use conda. That is easiest. I am not sure how well conda and Docker run on native Windows.

ADD REPLY

Login before adding your answer.

Traffic: 900 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6