ImportError: cannot import name expm3
1
0
Entering edit mode
2.3 years ago

Dear all,

I am trying to use pool-HMM tool on my pooled-seq data. It requires python version < 3 and I have python2.7. But the module SciPy was missing. So, i tried to install it with command:

pip2 install scipy

Now, whenever i try to run my pool-HMM command it gives error:

 Traceback (most recent call last):
  File "pool-hmm.py", line 20, in <module>
    from pred import prediction
  File "/media/tania/TM/WG_pooled_seq_analysis/PoolHMM-master/Modules/pred.py", line 2, in <module>
    from scipy.linalg import expm3
ImportError: cannot import name expm3

Please help me out how to resolve this issue? Any help would be highly appreciated.

Thanks in advance

linuxOS Pool-HMM SciPy python2 • 948 views
ADD COMMENT
1
Entering edit mode
2.3 years ago
Mensur Dlakic ★ 27k

Part of the answer to your question is here. Briefly, expm3 function was removed from scipy a long time ago, which tells me that the script you are using is very old as it relies on ancient functions. Maybe forcing the installation of an old scipy release will work, but beware that it will probably lack functionality that more recent scripts may need.

pip2 install scipy==0.12.1
ADD COMMENT
0
Entering edit mode

I am really grateful to you. It worked, many thanks for your help.

ADD REPLY

Login before adding your answer.

Traffic: 2684 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6