Running fastqc
1
0
Entering edit mode
9 weeks ago
margo ▴ 20

I am trying to run fastqc from my home directory using the command line. I do not have access to the root directory. I have downloaded fastqc zip file and unzipped it. When going into the FastQC directory, the following options are available:

Configuration,
LICENSE_JHDF5.txt
cisd-jhdf5.jar
net
uk
Help
README.txt
fastqc
org
INSTALL.txt
RELEASE_NOTES.txt
fastqc_icon.ico
run_fastqc.bat
LICENSE.txt
Templates
jbzip2-0.9.jar
sam-1.103.jar

However, when I try to run fastqc, an error message appears:

Command 'fastqc' not found, but can be installed with:
apt install fastqc
Please ask your administrator.

Is there something that I am doing wrong? How can I install fastqc in your home space as you don't have root on the server and run the programme?

fastqc • 322 views
ADD COMMENT
1
Entering edit mode

Please use conda to install FastQC. No root privileges are needed for this method. You will need a working X11 install otherwise you will have to download the resulting html files for viewing on your local machine.

Use conda part of tutorial here: Creating workflows with snakemake and conda

conda create -n fastqc fastqc 
conda activate fastqc
fastqc your_fastq_file_list
ADD REPLY
0
Entering edit mode

Yes, margo you downloaded the GUI version of FastQC. This isn't necessarily bad, you can drag and drop your fastq files into the gui, but doesn't lend itself to automation very well.

ADD REPLY
0
Entering edit mode
9 weeks ago

fastqc only requires java to be present, check the installation instructions here

https://raw.githubusercontent.com/s-andrews/FastQC/master/INSTALL.txt

as you can see if you have java running on your system, there is not much installation, to quote:

Actually installing FastQC is as simple as unzipping the zip file it comes in into a suitable location.

That's it.

Once unzipped it's ready to go.

ADD COMMENT

Login before adding your answer.

Traffic: 2139 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6