Problems installing cutadapt with conda
1
2
Entering edit mode
7 weeks ago

EDIT: SOLUTION

As rpolicastro said, the problem had to do with the conda channels. The solution for me was:

conda create -n cutadapt -c conda-forge -c bioconda cutadapt python=3.9

ORIGINAL POST

Hello everyone

I'm having trouble installing cutadapt.

I just installed conda and created a new environment for cutapdat with a specific python version (since it send me a message before about that).

conda create -n cutadapt python=3.9

When I enter the command conda install -c bioconda cutadapt the following message appears

UnsatisfiableError: The following specifications were found to be incompatible with each other:

Output in format: Requested package -> Available versionsThe following specifications were found to be incompatible with your system:

  - feature:/linux-64::__glibc==2.35=0
  - feature:|@/linux-64::__glibc==2.35=0
  - cutadapt -> libgcc-ng[version='>=9.3.0'] -> __glibc[version='>=2.17']

Your installed version is: 2.35

But when I run conda list in my cutadapt environment to see the packages it says:

packages in environment at /home/camila/miniconda3/envs/cutadapt:

Name                    Version                   Build  Channel
_libgcc_mutex             0.1                        main  
_openmp_mutex             4.5                       1_gnu   
ca-certificates           2022.4.26            h06a4308_0   
certifi   2021.10.8        py39h06a4308_2   
ld_impl_linux-64          2.35.1               h7274673_9   
libffi                    3.3                  he6710b0_2 

libgcc-ng                 9.3.0               h5101ec6_17   
libgomp   9.3.0               h5101ec6_17   
libstdcxx-ng              9.3.0               hd4cf53a_17   
ncurses                   6.3                 h7f8727e_2   
openssl                   1.1.1o               h7f8727e_0
pip                       21.2.4           py39h06a4308_0   
python    3.9.12               h12debd9_0   
readline                  8.1.2                h7f8727e_1    
setuptools                61.2.0           py39h06a4308_0
sqlite                    3.38.3               hc218d9a_0   
tk        8.6.11               h1ccaba5_1   
tzdata                    2022a                hda174b7_0   
wheel                     0.37.1             pyhd3eb1b0_0
xz                        5.2.5                h7f8727e_1   
zlib      1.2.12               h7f8727e_2

So I don't know what the problem may be. Any thoughts?

Thanks a lot.

bioconda cutadapt linux • 588 views
ADD COMMENT
1
Entering edit mode

Did you activate the environment before installing? You have shown the command to create a new env, install cutadapt to the base env and a list of packages in the new env.

ADD REPLY
0
Entering edit mode

Yes, I activated the new environment and there I tried to install cutadapt.

ADD REPLY
0
Entering edit mode

As a side note, when you create the environment you can add cutadapt during that step too.

conda create -n cutadapt cutadapt python=3.9

I just checked and this resolved for me.

ADD REPLY
0
Entering edit mode

Didn't help. The same message pops up.

> Package python conflicts for: python=3.9 cutadapt ->
> python[version='2.7.*|3.5.*|3.6.*|>=2.7,<2.8.0a0|>=3.6,<3.7.0a0|>=3.7,<3.8.0a0|>=3.9,<3.10.0a0|>=3.8,<3.9.0a0|>=3.5,<3.6.0a0|3.4.*']
> cutadapt -> dataclasses[version='>=0.7'] ->
> python[version='>=3.6,<3.7|>=3.7']The following specifications were
> found to be incompatible with your system:
> 
>   - feature:/linux-64::__glibc==2.35=0
>   - cutadapt -> libgcc-ng[version='>=9.3.0'] -> __glibc[version='>=2.17']
>   - python=3.9 -> libgcc-ng[version='>=7.5.0'] -> __glibc[version='>=2.17']
> 
> Your installed version is: 2.35
ADD REPLY
5
Entering edit mode
7 weeks ago

It could be related to your channels or the solver is having a problem with your specific linux install.

First try ensuring proper channel order when you go to create the environment.

conda create -n cutadapt -c conda-forge -c bioconda cutadapt python=3.9

If that doesn't work try using the beta libmamba solver which is more powerful than the current one.

conda update -n base conda
conda install -n base conda-libmamba-solver

conda create -n cutadapt --experimental-solver=libmamba -c conda-forge -c bioconda cutadapt python=3.9
ADD COMMENT
1
Entering edit mode

THANKS A LOT!!! That worked perfectly. Seems it was indeed a problem with the channels. Have a great day!

ADD REPLY
1
Entering edit mode

A small educational note: if an answer was helpful, you should upvote it; if the answer resolved your question, you should mark it as accepted. You can accept more than one answer if they work. This will help future users that might find this post find the right answer.

upvote_bookmark_accept

ADD REPLY
0
Entering edit mode

Thanks. I didn't know about the "Accept" button. I just did it.

ADD REPLY

Login before adding your answer.

Traffic: 1615 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6