error in downloading of some accesions with fastq-dump
1
0
Entering edit mode
11 months ago
pavelasquezv ▴ 50

Hi all,

When I'm running fastq-dump with some accessions everything works fine, for example:

fastq-dump --split-files SRR10345445 Results are ok

when I am running the program with other access codes I get an error, for example:

fastq-dump --split-files SRR5631167

connection failed while opening file within cryptographic module - mbedtls_ssl_handshake returned -9984 ( X509 - Certificate verification failed, e.g. CRL, CA or signature check failed )
2022-06-15T18:43:42 fastq-dump.2.9.6 sys: mbedtls_ssl_get_verify_result returned 0x8 (  !! The certificate is not correctly signed by the trusted CA )
2022-06-15T18:43:42 fastq-dump.2.9.6 sys: connection failed while opening file within cryptographic module - ktls_handshake failed while accessing '52.217.164.177' from '143.107.211.130'
2022-06-15T18:43:42 fastq-dump.2.9.6 sys: connection failed while opening file within cryptographic module - Failed to create TLS stream for 'sra-pub-run-odp.s3.amazonaws.com' (52.217.164.177) from '143.107.211.130''

This error only happens when I run the program on the server, because from my pc everything works fine.

Please, does anyone know how to fix this problem? I have many sequences to download :(

Many thanks

fastq-dump • 4.0k views
ADD COMMENT
0
Entering edit mode

sounds like the security certificate handed out by your server is not valid (or at least not signed or recognized).

I think your best option is to contact your server admin and see what you need/can do.

ADD REPLY
0
Entering edit mode

There are another way to make download of the runs by the server?

ADD REPLY
0
Entering edit mode

you can try going via ENA?

you can use this webtool to get download links (several ways) : sra-explorer.info

(perhaps you can also get alternative ways to download from SRA)

ADD REPLY
0
Entering edit mode

Many thanks for you reply. I will try!

Best wishes!

ADD REPLY
0
Entering edit mode

Hi, could you please let me know how to upgrade sratoolkit in centos? Thanks and regards,

ADD REPLY
1
Entering edit mode
11 months ago
pavelasquezv ▴ 50

Hi all,

The problem was solved when I updated the version of the SRA-Toolkit to v3.0. The link dependencies that link up to the cloud storage systems break on older versions of SRA-Toolkit.

I thought it was important to mention

Many thanks

ADD COMMENT
1
Entering edit mode

Thanks for posting this, I am having the same issue with v2.9.1, so I will check if upgrading to v3.0 will solve this issue.

ADD REPLY

Login before adding your answer.

Traffic: 2350 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6