Trim Galore Anaconda
1
0
Entering edit mode
23 months ago
Sudeep • 0

Hi, I am new to using the Linux terminal in Windows and I tried to install the Trim Galore package using Anaconda3 but keep getting this error:

(base) skhadka@DESKTOP-92U9DF6:~$ conda install -c bioconda trim-galore
Collecting package metadata (current_repodata.json): done
Solving environment: failed with initial frozen solve. Retrying with flexible solve.
Solving environment: failed with repodata from current_repodata.json, will retry with next repodata source.
Collecting package metadata (repodata.json): done
Solving environment: failed with initial frozen solve. Retrying with flexible solve.
Solving environment: |
Found conflicts! Looking for incompatible packages.
This can take several minutes.  Press CTRL-C to abort.
failed

UnsatisfiableError: The following specifications were found to be incompatible with each other:

Output in format: Requested package -> Available versionsThe following specifications were found to be incompatible with your system:

  - feature:/linux-64::__glibc==2.35=0
  - feature:|@/linux-64::__glibc==2.35=0

Your installed version is: 2.35

Has anyone resolved this issue or will help me with it? Thanks in advance!!

chip-seq rna-seq • 2.7k views
ADD COMMENT
0
Entering edit mode

Try with conda install -c bioconda -c conda-forge -c anaconda trim-galore.

ADD REPLY
0
Entering edit mode

Hi Arup Thanks for your response. Its showing the same issue.

ADD REPLY
0
Entering edit mode

Rather than installing in base create another environment for trim-galore.

conda create -n trimgalore_env -c bioconda -c conda-forge -c anacond trim-galore
ADD REPLY
0
Entering edit mode

It worked. Thank you very much!!

ADD REPLY
0
Entering edit mode
23 months ago
Trivas ★ 1.8k

You need to install WSL (Windows Subsystem for Linux). The linux terminal in windows is not a true linux distributable and you cannot install linux programs with it.

ADD COMMENT
0
Entering edit mode

Hi Trivas, I have installed Windows Subsystem for Linux. I tried installing other packages (like fastqc) and it worked fine for that. But I am having trouble with this one. Do you have any idea about that?

ADD REPLY

Login before adding your answer.

Traffic: 3208 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6