Encountering error while using sudo apt-get update command
0
0
Entering edit mode
19 months ago

Hello everybody,

I am trying to download a packages and initially running the update command

sudo apt-get update

But I get the following error

Hit:1 http://dl.google.com/linux/chrome/deb stable InRelease Hit:2 http://pk.archive.ubuntu.com/ubuntu focal InRelease
Get:3 http://security.ubuntu.com/ubuntu focal-security InRelease [114 kB]
Hit:4 http://update.send-anywhere.com/linux/debian stable InRelease
Hit:5 http://ppa.launchpad.net/c2d4u.team/c2d4u4.0+/ubuntu focal InRelease
Ign:6 http://www.stats.bris.ac.uk/R/bin/linux/ubuntu precise/ InRelease
Get:7 http://pk.archive.ubuntu.com/ubuntu focal-updates InRelease [114 kB]
Err:8 http://www.stats.bris.ac.uk/R/bin/linux/ubuntu precise/ Release 404 Not Found [IP: 137.222.10.189 80] Get:9 http://ppa.launchpad.net/marutter/rrutter3.5/ubuntu focal InRelease [17.5 kB]
Hit:10 https://cloud.r-project.org/bin/linux/ubuntu focal-cran40/ InRelease Get:11 http://pk.archive.ubuntu.com/ubuntu focal-backports InRelease [108 kB] Get:12 http://security.ubuntu.com/ubuntu focal-security/main amd64 DEP-11 Metadata [40.7 kB] Get:13 http://security.ubuntu.com/ubuntu focal-security/universe amd64 DEP-11 Metadata [94.2 kB] Get:14 http://pk.archive.ubuntu.com/ubuntu focal-updates/main amd64 DEP-11 Metadata [275 kB] Get:15 http://security.ubuntu.com/ubuntu focal-security/multiverse amd64 DEP-11 Metadata [940 B] Get:16 http://pk.archive.ubuntu.com/ubuntu focal-updates/universe amd64 DEP-11 Metadata [406 kB] Get:17 http://pk.archive.ubuntu.com/ubuntu focal-updates/multiverse amd64 DEP-11 Metadata [940 B] Get:18 http://pk.archive.ubuntu.com/ubuntu focal-backports/main amd64 DEP-11 Metadata [8,012 B] Get:19 http://pk.archive.ubuntu.com/ubuntu focal-backports/universe amd64 DEP-11 Metadata [30.5 kB] Reading package lists... Done
E: The repository 'http://www.stats.bris.ac.uk/R/bin/linux/ubuntu precise/ Release' does not have a Release file. N: Updating from such a repository can't be done securely, and is therefore disabled by default. N: See apt-secure(8) manpage for repository creation and user configuration details.

Anybody please help me out in resolving this issue. Any help would be highly appreciated

Thanks in advance

ubuntu offtopic • 1.2k views
ADD COMMENT
0
Entering edit mode

This post does not fit the theme of this forum. In fact, the error message says it all, ask the repository maintainer for a solution, they can fix it.

ADD REPLY
0
Entering edit mode

Okay, sorry for the inconvenience. I will be careful next time. Thanks for your guidance

ADD REPLY
1
Entering edit mode

No problem at all. Note that this is likely just a version mismatch, your Ubuntu version is Focal (fossa) and the repository is precise (pangolin). Removing the repo from your sources and replacing it with the right version should do it.

ADD REPLY

Login before adding your answer.

Traffic: 1434 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6