TDF to bed graph -- IGV on command line
0
0
Entering edit mode
8 weeks ago
a_bis ▴ 30

Hi all, I'm trying to convert some TDF files to bedgraph files so that I can do a genomic leftover on them (as far as I can tell, I can't lift over TDF files). This google group answer here (https://groups.google.com/g/igv-help/c/RcZw5YB5SOQ) says I can run igvtools on the command line and convert a TDF file to a bedgraph (this command can't be run through the GUI), and then proceed from there. However, I'm having a hard time running the command on the command line. I'm in a directory that contains both a version of IGV as well as the .tdf file that I want to convert to .bedgraph. When I run

igvtools tdftobedgraph input.tdf output.bedgraph

I get a

-bash: igvtools: command not found

message.

I also tried the following:

   java -Xmx1500m --module-path=lib @igv.args --module=org.igv/org.broad.igv.tools.IgvTools tdftobedgraph GSM1782914_Smad2_3_D3EB_AC_E14.tdf GSM1782914_Smad2_3_D3EB_AC_E14.bedgraph

Unrecognized option: --module-path=lib
Error: Could not create the Java Virtual Machine.
Error: A fatal exception has occurred. Program will exit.

Could anybody advise on what exactly I should do to get IGV to run on the command line successfully? Thanks in advance!

tdf igv • 287 views
ADD COMMENT
0
Entering edit mode

This looks like the classic $PATH problem. If you are in the IGV install directory you may simply need to do ./igvtools and/or add the directory to your $PATH.

ADD REPLY
0
Entering edit mode

Hi GenoMax, many thanks for the reply. I'm not in the install directory (I'm not sure where it is -- is it most likely the Applications directory where new downloaded apps are generally automatically installed?), but in a directory I made where I moved the IGV app and the relevant .tdf files. I'm not sure how to go about finding the install directory -- sorry to bug you again, but if you could give me a pointer as to how to how to find the install directory and add it to the $PATH, I'd be very grateful!

ADD REPLY
0
Entering edit mode

(I also tried running ./igvtools [command] [input] [output] and it gave me the same error message!)

ADD REPLY

Login before adding your answer.

Traffic: 1741 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6