Problems with perl-xml-parser-2.44-4
0
0
Entering edit mode
8 weeks ago
Юлия ▴ 10

Hello everyone! I tried to install this tool: https://github.com/zhangrengang/SubPhaser

However, when I try to install needed packages from .yaml file, I get such errors (see figure). I tried to do this by mamba, I installed perl-xml-parser-lite, and perl version is v5.22.0.

I have no idea.... Thank everyone in advance for advice.

errors

packages perl-xml-parser mamba • 515 views
ADD COMMENT
2
Entering edit mode

You have already done this in a separate thread, so I feel compelled to tell you: I can't read anything in these figure without getting within an inch of a monitor. Maybe you and others have better eyes than mine, but chances are there are other readers with a similar problem.

I suggest you paste a properly formatted text containing the error message rather than these images.

ADD REPLY
0
Entering edit mode

Sorry please for this format. :(

ADD REPLY
0
Entering edit mode

Do this. Copy and paste the text data in editor window. Then use 101010 button in the edit bar to format it as code.

So it looks like this

If you post screenshots then people are not able to grab the text if it is required to test something.

ADD REPLY
0
Entering edit mode

Sorry, I am new here)))

Output from conda:

  - xorg-xextproto==7.3.0=h7f98852_1002 -> libgcc-ng[version='>=9.3.0'] -> __glibc[version='>=2.17']
  - xorg-xproto==7.0.31=h7f98852_1007 -> libgcc-ng[version='>=9.3.0'] -> __glibc[version='>=2.17']
  - xz==5.2.5=h516909a_1 -> libgcc-ng[version='>=7.5.0'] -> __glibc[version='>=2.17']
  - zlib==1.2.11=h516909a_1010 -> libgcc-ng[version='>=7.5.0'] -> __glibc[version='>=2.17']
  - zstd==1.5.0=ha95c52a_0 -> libgcc-ng[version='>=9.3.0'] -> __glibc[version='>=2.17']

Your installed version is: 2.31

Output from mamba:

Could not solve for environment specs
Encountered problems while solving:
  - package perl-xml-parser-2.44-4 requires perl >=5.22.0,<5.23.0, but none of the providers can be installed

The environment can't be solved, aborting the operation
ADD REPLY
0
Entering edit mode

Much better, thank you. It seems pretty clear that this package requires a very narrow range of perl versions - >=5.22.0 and <5.23.0 can't be more than a couple minor versions, and it doesn't surprise me that conda can't handle it.

You may need to find the source code for this package and install it via its Makefile.PL, or find a way to solve your problem without this particular package.

ADD REPLY
0
Entering edit mode

Please could you explain hoe to make Makefile.PL in my case?

ADD REPLY
0
Entering edit mode

A general way of installing perl modules via CPAN is described here. You will have to find your exact package, but I suspect it might be here.

ADD REPLY

Login before adding your answer.

Traffic: 3201 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6