When I run Trimmomatic, I continue to get an "unknown trimmer" error and cannot figure out how to fix it.
0
0
Entering edit mode
18 months ago

I have applied following in the folder where the data is:

java -jar Trimmomatic-0.39/trimmomatic-0.39.jar PE phred33 /home/*/*R1.fastq.gz /home/*/*R2.fastq.gz *R1.trimmed.fastq.gz *R1.untrimmed.fastq.gz *R2.trimmed.fastq.gz *R2.untrimmed.fastq.gz ILLUMINACLIP:/home/Trimmomatic/adapters/TruSeq3-SE.fa:2:30:7 MINLEN:15

the output i got:

TrimmomaticPE: Started with arguments:
phred64 /home/*/*R1.fastq.gz /home/*/*R2.fastq.gz *R1.trimmed.fastq.gz *R1.untrimmed.fastq.gz *R2.trimmed.fastq.gz *R2.untrimmed.fastq.gz ILLUMINACLIP:/home/trimmomatic/adapters/TruSeq3-SE.fa:2:30:7 MINLEN:15
Exception in thread "main" java.lang.RuntimeException: Unknown trimmer: *R2.untrimmed.fastq.gz
    at org.usadellab.trimmomatic.trim.TrimmerFactory.makeTrimmer(TrimmerFactory.java:73)
    at org.usadellab.trimmomatic.Trimmomatic.createTrimmers(Trimmomatic.java:59)
    at org.usadellab.trimmomatic.TrimmomaticPE.run(TrimmomaticPE.java:552)
    at org.usadellab.trimmomatic.Trimmomatic.main(Trimmomatic.java:80)
trimmomatic • 1.7k views
ADD COMMENT
0
Entering edit mode

don't use those stars and use the real files without globbing , and then update your post for a start.

ADD REPLY
0
Entering edit mode

Hi, I used real files only. here I just pasted the format that I used while trimming.

ADD REPLY
1
Entering edit mode

Even if you used real file names, home/*/ seems like a suspect path. Do you have a directory called home in which ever directory you are running this from? Looks like that may need to start with a /home if you are referring to files in your home directory.

A similar issue may exist in this path trimmomatic/adapters/TruSeq3-SE.fa.

ADD REPLY
0
Entering edit mode

Thanks, but it still showing unknown trimmer: <the output file>

ADD REPLY
1
Entering edit mode

Assuming you have the right number of options provided this is going to be a path issue. Make sure the file with adapter sequence exists. Provide full path to /full_path_to/TruSeq3-SE.fa.

ADD REPLY
0
Entering edit mode

hi, I provide full path, but it still shows same

ADD REPLY
0
Entering edit mode

Can you post the commandline again here, after you have fixed/implemented all of GenoMax remarks.

Thanks

ADD REPLY
0
Entering edit mode

Do not delete posts that have received feedback. Interact with the people that have invested effort into helping you, and work towards providing closure to your post.

ADD REPLY

Login before adding your answer.

Traffic: 4117 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6