STAR GeneCounts for most genes are 0
0
0
Entering edit mode
8 months ago

Hello all, I am relatively new to this field.

I am doing an RNA-seq alignment and expecting a gene count output for a prokaryote genome. I have an annotation GTF file in which I have converted the third column into "exon" for the alignment to work. Everything seemed well but the readspergene.out.tab file has mostly 0 for the gene counts.example genecount output

Can anyone help diagnose what the problem is? Thank you

STAR RNA-seq • 561 views
ADD COMMENT
0
Entering edit mode

What STAR commands did you run for generating the genome index and for aligning? Also, you may want to share both the STAR alignment log and a few lines from your modified GTF file.

ADD REPLY
0
Entering edit mode

It looks like most of the reads aligned outside your annotated “transcripts”. I would double-check that your annotations are in the same coordinate system as your genome.

ADD REPLY
0
Entering edit mode

a prokaryote genome ... I have converted the third column into "exon"

I guess the problem is somewhere here and agree that you should post an excerpt from your GTF file. Coming from a prokaryote that doesn't have splicing it is likely not in a proper format and lacks exon annotation (and changing only the type from CDS or whatever to exon doesn't cut it). In principle, you won't even need a splicing aligner here at all for that matter.

ADD REPLY

Login before adding your answer.

Traffic: 2853 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6