perl Error - needLargeMem Bigwig
0
0
Entering edit mode
4 weeks ago
marco.barr ▴ 150

Hello everyone, I am running a complex pipeline on fastq files with a Perl script. At some point in the output, I get this strange error that I have never seen before in this analysis.

/home/MitoSAlt/bin/last-1542/bin/lastal: can't open file: tmp_MT10617M_S6.fq
Fri May 24 14:56:24 2024: Generate Bigwig
needLargeMem: trying to allocate 0 bytes (limit: 100000000000)
Use of uninitialized value $elements[6] in pattern match (m//) at MitoSAlt1.1.1_mod.pl line 221, 
<CONFIG> line 64.

This is my command

perl MitoSAlt1.1.1_mod.pl config_human.txt file_R1.fastq file_R2.fastq sample_name

It's probably due to the fact that I receive an empty file as input? I don't understand how to fix it. I ran the same pipeline a few minutes ago on other samples, without making any changes to the Perl script, and everything worked fine. Maybe it's the samples? I ran it both on a slurm cluster and on a login node. And always the same error. Thank you very much for your help.

Bigwig perl mitosalt • 311 views
ADD COMMENT
0
Entering edit mode

A quick search suggests the problem is your empty input file? See https://biostar.galaxyproject.org/p/6794

ADD REPLY
0
Entering edit mode

I managed to correct and solve the problem. It was due to issues with memory parameter settings on different login nodes. Additionally, I had mistakenly left a hyphen on a line of the script. Thank you very much anyway.

ADD REPLY

Login before adding your answer.

Traffic: 2278 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6