Edit Blast Not Finding Locally Downloaded Database (Nr) Local Blastn Stopping Early
1
0
Entering edit mode
10.5 years ago
jrymer1 ▴ 30

I downloaded nr locally and am trying to BLAST my fasta files against the nr database. I don't get an error but when I check the out file it looks as though it stops early. It stops at the first run and doesn't do a comparison, only prints the reference names, version, and the 1st query. I'm using...

blastall -p blastn -d nr -i inputfile.fasta -o output.out

Is it not finding nr to make a comparison to?

I downloaded the "per-formatted" databases from NCBI, and after unpacking have .phd .phi .phr .pin .pnd .pni .pog .ppd .ppi .psd .psi and .psq files. Are these per-formatted?

blastn • 4.2k views
ADD COMMENT
0
Entering edit mode

I'm not sure if this is related to your issue, but the 'blastall' program has been deprecated. The newer versions are a little easier to work with, as a nice bonus. http://www.biostars.org/post/show/1557/help-with-formatdb-and-blast-all/#1558

ADD REPLY
0
Entering edit mode

I tried using it without blastall in the format from the link you gave me and it said it could not find blastn even when I gave the direct path.

I know for sure it is because of the database. I removed the -d option and got the same result, which means it is not finding the locally downloaded pre-formatted NCBI database. how can I get it to find local nr?

ADD REPLY
0
Entering edit mode
10.5 years ago
Fwip ▴ 490

Oh, I think I have a better picture of what's going on. You're using "blastn" against "nr," which is a nucleotide search against a protein database. If you're trying to do a protein search, use "blastp." If you are trying to do a nucleotide search, try the "nt" database.

ADD COMMENT
0
Entering edit mode

http://blast.ncbi.nlm.nih.gov/Blast.cgi?CMD=Web&PAGE_TYPE=BlastDocs&DOC_TYPE=ProgSelectionGuide

It says that nr is under the "Nucleotide Databases for BLAST" section. Which should I download then for nucleotides? I tried telling update_blastdb.pl nt but it said nt was not found.

I was running it in virtual box, that is why it would not find nt.

ADD REPLY
0
Entering edit mode

Yes, if you have not fixed your earlier problem with running the update_blastdb.pl script in your virtualbox, it will continue to not work.

Has this question been resolved, then?

ADD REPLY
0
Entering edit mode

I got it working thanks. I downloaded update_database.pl through a server where it works.

ADD REPLY

Login before adding your answer.

Traffic: 2503 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6