Question: (Closed) . [Blastall] Warning: Unable To Open Bos.Db.Nin
0
gravatar for Manju
7.5 years ago by
Manju50
Manju50 wrote:

I created the database of 1 chr using makeblastdb tool of localblast. It showing me output, But it also showing me warning while i am blasting from programming. that ..

[blastall] WARNING: Unable to open bos.db.nin
[blastall] WARNING: Unable to open bos.db.nin
[blastall] WARNING: Unable to open bos.db.nin
[blastall] WARNING: Unable to open bos.db.nin
[blastall] WARNING: Unable to open bos.db.nin

.. is it an error or should i ignore this.bcs it showing me correct blast result.

R blast • 2.1k views
ADD COMMENTlink modified 7.2 years ago by Manju0 • written 7.5 years ago by Manju50
0
gravatar for Jonasr
7.5 years ago by
Jonasr120
Jonasr120 wrote:

.nin is the index file and should have been created when executing makeblastdb. Is the file present on the disk? What were the arguments fed to makeblastdb?
How are you calling blast? Are you sure it is using bos.db and not another database set as default on your system?

ADD COMMENTlink modified 7.5 years ago • written 7.5 years ago by Jonasr120

I crted the dbase for Bos_taurus using Formatdb cmd of blast. data$ formatdb -i Btau.fa -p F -o T

and ya ds file is exist in data dir of balst.and also showing blast output with this warning 5 times. [blastall] WARNING: Unable to open Batu.fa.nin . . . . [blastall] WARNING: Unable to open Batu.fa.nin program is:-

@params = ('database' => 'Btau.fa','outfile' => 'bla.out', 'prog'=> 'blastn');

$factory = Bio::Tools::Run::StandAloneBlast->new(@params); $str = Bio::SeqIO->new(-file=>'testquery.fa' , '-format' => 'Fasta' ); $input = $str->nextseq(); $factory->blastall($input);

Manju

ADD REPLYlink written 7.5 years ago by Manju50

Ok, seems good from what I can see. Maybe it's a BioPerl problem, I don't really know the package though. For a test you could try to run BLAST directly on the commandline and see if that works.

ADD REPLYlink written 7.5 years ago by Jonasr120

I am using Biperl 1.69 version..and it does nt showing any error while i am running blasall in commandline..it showing me same result without any warning...So what should i do with this warning??

ADD REPLYlink written 7.4 years ago by Manju50
Please log in to add an answer.
The thread is closed. No new answers may be added.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 1129 users visited in the last hour