Error in running kissplice2reftranscriptome
3
0
Entering edit mode
5.3 years ago
c.evang ▴ 10

Dear All and kissplice-users, I'm run into an error when running kissplice2reftranscriptome; the error was:

Opening all files and formatting tables...
Collecting data...
Traceback (most recent call last):
  File "/usr/local/bin/kissplice2reftranscriptome", line 5, in <module>
    pkg_resources.run_script('kissplice2reftranscriptomelib==1.3.0', 'kissplice2reftranscriptome')
  File "/usr/local/lib/python2.7/dist-packages/distribute-0.6.34-py2.7.egg/pkg_resources.py", line 505, in run_script
    self.require(requires)[0].run_script(script_name, ns)
  File "/usr/local/lib/python2.7/dist-packages/distribute-0.6.34-py2.7.egg/pkg_resources.py", line 1245, in run_script
    execfile(script_filename, namespace, namespace)
  File "/usr/local/lib/python2.7/dist-packages/kissplice2reftranscriptomelib-1.3.0-py2.7.egg/EGG-INFO/scripts/kissplice2reftranscriptome", line 556, in <module>
    main()
  File "/usr/local/lib/python2.7/dist-packages/kissplice2reftranscriptomelib-1.3.0-py2.7.egg/EGG-INFO/scripts/kissplice2reftranscriptome", line 458, in main
    element[11], element[12], element[13])
  File "/usr/local/lib/python2.7/dist-packages/kissplice2reftranscriptomelib-1.3.0-py2.7.egg/kissplice2reftranscriptomelib/ioFilesActions/outputFileWriter.py", line 63, in writeInMainTsvFileForSimpleSnp
    "\t" + readCountsVariant1 + "\t" + readCountsVariant2 + "\t" + str(isSpecificCondition) + "\n")
TypeError: cannot concatenate 'str' and 'list' objects

Thanks in advance for your help!

snp kissplice k2rt • 1.8k views
ADD COMMENT
0
Entering edit mode

Dear kissplice-users, I'm run into an error when running kissplice2reftranscriptome; the error was: enter image description here

Thanks for your help!

ADD REPLY
1
Entering edit mode
5.2 years ago

Dear Chiara and k2rt users, I apologise for my slow response on this forum. I had posted this message on the kissplice-users list, but I had forgotten to answer also on the forum. A new version of k2rt which solves this bug is now available here; http://kissplice.prabi.fr/tools/kiss2rt/ Thanks for reporting the bug !

Vincent

ADD COMMENT
0
Entering edit mode
5.3 years ago

Dear Chiara,

Thanks for reporting this bug. Could you send us an input file, with your command-line, so that we can debug? Thanks !

Kind regards.

ADD COMMENT
0
Entering edit mode

​​Dear Leandro, below the google drive link where the input files are deposited:

https://drive.google.com/open?id=0BxZ448pnAtJaTGpoNE9Cb2Y5bkE

And this is the command-line I used for running k2rt:

kissplice2reftranscriptome -b assemblychec095n10_okay_okalt_newnames.fasta.transdecoder.bed -k results_mDr1_EcoC_mDr2_EcoC_mDr3_EcoC_WW1_EcoC_WW2_EcoC_WW3_EcoC_k25_coherents_type_0a.fa -t out_blat_SNP_on_transcripts_80.psl -s kissDE_output_C_pvalue05

Thank you very much.

ADD REPLY

Login before adding your answer.

Traffic: 887 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6