Question: REAPR run error
1
gravatar for Anand Rao
16 months ago by
Anand Rao190
United States
Anand Rao190 wrote:

I am running REAPR version 1.0.18 (and also the older 1.0.17) to check for correctness of my genome assemblies.

However, I am getting a run error with the "smaltmap" step, and this error suggests that the input files are not in the correct format. Syntax used was:

reapr smaltmap a5miseq_EthFoc11_LOCAL.fsa EthFoc-11_S285_L007_R1_001.fastq.gz EthFoc-11_S285_L007_R2_001.fastq.gz a5miseq_EthFoc11_RawReads_mapped.bam

The complete STDOUT/STDERR is at this page - http://textuploader.com/djam1. Towards the end of the message, it reads (with BOTH versions)

# =-=-= End of Hash Index Stats =-=-=
# Sampling insert size distribution ...
[0] smalt.c:750 ERROR: wrong FASTQ/FASTA format 
[REAPR smaltmap] Error in system call:
/share/apps/reapr-1.0.17/src/smalt sample -u 1000 -o a5miseq_EthFoc11_RawReads_mapped.bam.tmp.9652.smaltmap.smalt_sample a5miseq_EthFoc11_RawReads_mapped.bam.tmp.9652.smaltmap.smalt_index EthFoc-11_S285_L007_R1_001.fastq.gz EthFoc-11_S285_L007_R2_001.fastq.gz
srun: error: c9-72: task 0: Exited with exit code 1

Despite the error message, outputs are generated, as shown below:

-rw-rw-r-- 1 aksrao aksrao    0 Sep 11 01:44 a5miseq_EthFoc11_RawReads_mapped.bam.tmp.9777.smaltmap.smalt_sample
-rw-rw-r-- 1 aksrao aksrao 318M Sep 11 01:44 a5miseq_EthFoc11_RawReads_mapped.bam.tmp.9777.smaltmap.smalt_index.smi
-rw-rw-r-- 1 aksrao aksrao  21M Sep 11 01:44 a5miseq_EthFoc11_RawReads_mapped.bam.tmp.9777.smaltmap.smalt_index.sma
-rw-rw-r-- 1 aksrao aksrao    0 Sep 11 01:31 a5miseq_EthFoc11_RawReads_mapped.bam.tmp.9652.smaltmap.smalt_sample
-rw-rw-r-- 1 aksrao aksrao 318M Sep 11 01:31 a5miseq_EthFoc11_RawReads_mapped.bam.tmp.9652.smaltmap.smalt_index.smi
-rw-rw-r-- 1 aksrao aksrao  21M Sep 11 01:30 a5miseq_EthFoc11_RawReads_mapped.bam.tmp.9652.smaltmap.smalt_index.sm

Interestingly, I've used these same input files successfully (PE 2*150 HiSeq4K R1, R2 files) with other software / tools including Trimmomatic, ALLPATHS-LG, bbduk.sh / tadpole.sh.

Importantly, I've used these same input files for the "perfectmap" step of reapr analyses, without any run errors! The syntax was:

reapr perfectmap a5miseq_EthFoc11_LOCAL.fsa EthFoc-11_S285_L007_R1_001.fastq.gz EthFoc-11_S285_L007_R2_001.fastq.gz 150 perfect

and generated the following outputs:

-rw-rw-r-- 1 aksrao aksrao  51K Sep 11 01:08 perfect.perfect_cov.gz.tbi
-rw-rw-r-- 1 aksrao aksrao  946 Sep 11 01:08 perfect.hist
-rw-rw-r-- 1 aksrao aksrao 153M Sep 11 01:08 perfect.perfect_cov.gz

So I am not sure what this "wrong FASTQ/FASTA format" error message means, and why it even appears. Could someone help me debug this please? Thank you!

smalt run error reapr • 647 views
ADD COMMENTlink modified 16 months ago • written 16 months ago by Anand Rao190
0
gravatar for Anand Rao
16 months ago by
Anand Rao190
United States
Anand Rao190 wrote:

The reasons for this error is straightforward:

The input file format/extension for this step of reapr has to be *.fastq and not *.gz (as I understand it)

I consider this solved...

ADD COMMENTlink modified 16 months ago • written 16 months ago by Anand Rao190
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 1176 users visited in the last hour