Question: biomaRt query Error "no upstream flank found"
1
gravatar for shatabdisen40
13 days ago by
shatabdisen4010 wrote:

Upstream_flank is an attribute in biomart,how can i use my python script to retrieve the upstream_flank with a value of 1000.

I generated the following xml query:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE Query>
<Query  virtualSchemaName = "zome_mart" formatter = "FASTA"
header = "0" uniqueRows = "1" count = ""
datasetConfigVersion = "0.6" >
    <Dataset name = "phytozome" interface = "default" >
    <Filter name = "organism_id" value = "447"/>
    <Filter name = "upstream_flank" value = "500"/>
    <Attribute name = "gene_name1" />
    <Attribute name = "transcript_name1" />
    <Attribute name = "transcript_exon_intron" />
    <Attribute name = "organism_name" />
    <Attribute name = "chr_name1" />
    <Attribute name = "gene_chrom_start" />
    <Attribute name = "gene_chrom_end" />
    <Attribute name = "gene_chrom_strand" />
    <Attribute name = "transcript_id" />
    <Attribute name = "transcript_chrom_start" />
    <Attribute name = "transcript_chrom_end" />
    <Attribute name = "peptide_name" />
    <Attribute name = "exon_chrom_start" />

</Dataset>

</query>

but this query is not working and its throwing biomaRt query Error "no upstream flank found" .

I know the issue can be solved by using Biomart package in R but I have written all my code in python and hence want to resolve the issue in python.

Kindly assist me in solving this error.

sequence biomart • 96 views
ADD COMMENTlink modified 6 days ago • written 13 days ago by shatabdisen4010

Thank you for the clarification, I will try to look into this in detail.

ADD REPLYlink written 6 days ago by shatabdisen4010
1
gravatar for Mike Smith
11 days ago by
Mike Smith1.2k
EMBL Heidelberg / de.NBI
Mike Smith1.2k wrote:

I think this is a problem with the current version of Ensembl BioMart, and I would recommending testing your code against the most recent archive version. There have been similar reports when using biomaRt (e.g. https://support.bioconductor.org/p/120429/), and currenty I don't think the flanking sequence retrieval is working. AFAIK the Ensembl team are looking into it.


Actually, on closer look, I'm not sure you can combine the transcript_exon_intron sequence attribute with the upstream_flank filter. I don't know the Mart well enough to be sure, but for human genes it would need to be something like gene_flank or coding_gene_flank. transcript_exon_intron is limited to Exon/intron regions and the flanking filter is meaningless for it.

ADD COMMENTlink modified 10 days ago • written 11 days ago by Mike Smith1.2k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 1990 users visited in the last hour