Question: ReactomePA only showing one pathway
0
gravatar for 200dumplings
17 months ago by
200dumplings10
200dumplings10 wrote:

After I run the enrichPathway() on my genelist, I tried to visualize it using barplot(), but it is only showing one enrichment pathway. In my S4 results, I have definitely more than 1. I was wondering if anyone can help?

My input data looks like this

head(genelist,50)

[1] 14013 76589 69513 11668 245578 13386 665700 13850 12511 NA NA 109620 [13] 20324 57349 14165 18591 NA 319189 434215 245404 381122 12346 242050 19074 [25] 74088 71685 72027 330355 NA 216350 13070 77453 72388 75766 634104 NA [37] 19124 68895 22431 21859 231238 211612 109648 NA 74603 71884 57440 19824 [49] NA 17912

Parameters I used for enrichPathway():

down_204_pathway_enr <- enrichPathway(genelist, organism = "mouse", pvalueCutoff = 0.05)

It ran. However, when I view the dataframe, it only shows me one dataframe

head(as.data.frame(down_204_pathway_enr))

ID Description GeneRatio BgRatio R-MMU-9007101 R-MMU-9007101 Rab regulation of trafficking 21/588 106/8755 pvalue p.adjust qvalue R-MMU-9007101 5.863062e-06 0.00453801 0.004412726 geneID R-MMU-9007101 72433/320560/105841/207592/108995/71648/235633/74030/209773/270160/66687/70785/381605/216363/22241/11891/329260/233204/19325/242406/66691 Count R-MMU-9007101 21

When I run visualization barplot(down_204_pathway_enr, showCategory=8) It only shows me one pathway.

My Sessioninfo looks like this

R version 3.6.0 (2019-04-26) Platform: x86_64-apple-darwin15.6.0 (64-bit) Running under: macOS Mojave 10.14.3

Matrix products: default BLAS: /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A/libBLAS.dylib LAPACK: /Library/Frameworks/R.framework/Versions/3.6/Resources/lib/libRlapack.dylib

Random number generation: RNG: Mersenne-Twister Normal: Inversion Sample: Rounding locale: [1] enCA.UTF-8/enCA.UTF-8/enCA.UTF-8/C/enCA.UTF-8/en_CA.UTF-8

attached base packages: [1] parallel stats4 stats graphics grDevices utils datasets methods [9] base

other attached packages: [1] graphite1.30.0 org.Mm.eg.db3.8.2 AnnotationDbi1.46.0 IRanges2.18.0 [5] S4Vectors0.22.0 Biobase2.44.0 BiocGenerics0.30.0 biomaRt2.40.0 [9] ReactomePA_1.28.0

loaded via a namespace (and not attached): [1] bitops1.0-6 enrichplot1.4.0 bit640.9-7 RColorBrewer1.1-2 [5] progress1.2.2 httr1.4.0 UpSetR1.4.0 tools3.6.0 [9] backports1.1.4 R62.4.0 DBI1.0.0 lazyeval0.2.2 [13] colorspace1.4-1 tidyselect0.2.5 gridExtra2.3 prettyunits1.0.2 [17] curl3.3 bit1.1-14 compiler3.6.0 graph1.62.0 [21] xml21.2.0.9000 labeling0.3 triebeard0.3.0 scales1.0.0 [25] checkmate1.9.3 ggridges0.5.1 rappdirs0.3.1 stringr1.4.0 [29] digest0.6.19 DOSE3.10.1 pkgconfig2.0.2 rlang0.3.4 [33] rstudioapi0.10 RSQLite2.1.1 gridGraphics0.4-1 farver1.1.0 [37] jsonlite1.6 BiocParallel1.18.0 GOSemSim2.10.0 dplyr0.8.1 [41] RCurl1.95-4.12 magrittr1.5 ggplotify0.0.3 GO.db3.8.2 [45] Matrix1.2-17 Rcpp1.0.1 munsell0.5.0 viridis0.5.1 [49] stringi1.4.3 ggraph1.0.2 MASS7.3-51.4 plyr1.8.4 [53] qvalue2.16.0 grid3.6.0 blob1.1.1 ggrepel0.8.1 [57] DO.db2.9 crayon1.3.4 lattice0.20-38 cowplot0.9.4 [61] splines3.6.0 hms0.4.2 pillar1.4.1 fgsea1.10.0 [65] igraph1.2.4.1 reshape21.4.3 fastmatch1.1-0 XML3.98-1.19 [69] glue1.3.1 data.table1.12.2 BiocManager1.30.4 tweenr1.0.1 [73] urltools1.7.3 gtable0.3.0 purrr0.3.2 polyclip1.10-0 [77] assertthat0.2.1 ggplot23.1.1 ggforce0.2.2 europepmc0.3 [81] reactome.db1.68.0 viridisLite0.3.0 tibble2.1.2 rvcheck0.1.3 [85] memoise_1.1.0

Can someone please help me out and point out what is wrong?

reactome reactomepa • 373 views
ADD COMMENTlink written 17 months ago by 200dumplings10
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 1492 users visited in the last hour