Question: bayenv2: "initial epsilon zero or 1 locus 6912"
0
gravatar for biosol
20 months ago by
biosol150
biosol150 wrote:

Hi everyone,

currently I'm running bayenv2 on my data. First,I've converted my vcffile into bayenvformat but then, when I try to generate the covariance matrix, I get the message initial epsilon zero or 1 locus 6912. I've read that the epsilon value in bayenv2is related to the allele frequency at a specific locus for the current generation, but don't actually understand what this means and I don't know how to solve this problem.

Any help will be appreciated! Thank you very much in advanced :)

bayenv2 snps • 539 views
ADD COMMENTlink modified 19 months ago by katuckele10 • written 20 months ago by biosol150
1
gravatar for katuckele
19 months ago by
katuckele10
katuckele10 wrote:

Hi Sonia,

I had this error message too. I checked my SNP file and sure enough, the locus referenced by the error message was fixed in all populations, e.g.:

0 0 0 0 0 0

20 20 20 20 20 20

I took out this locus and Bayenv runs without error.

Hope this helps, Katie

ADD COMMENTlink modified 19 months ago • written 19 months ago by katuckele10

Hi Katie, thank you very much for your answer! I asked the developpers of the bayenv2 and they told me that the problem was that the file contained SNPs with fixed allele frequencies (the same allele in all individuals, either 0 or 1). So I filtered my data by MAF 1% and the problems was solved. I think this matches as well with your case, your allele freqs were fixed for that SNP!

ADD REPLYlink written 19 months ago by biosol150
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 1579 users visited in the last hour
_