Question: Deeptools installation fails (Could not find a version that satisfies the requirement matplotlib>=3.1.0)
0
gravatar for DBScan
4 days ago by
DBScan20
DBScan20 wrote:

I am trying to install deeptools, but I always get the following error:

Collecting deeptools
  Using cached https://files.pythonhosted.org/packages/f6/f3/789edda975fcca4736fab2007d82cab2e86739901c88bb0528db5c338d1f/deepTools-3.5.0.tar.gz
Collecting numpy>=1.9.0 (from deeptools)
  Using cached https://files.pythonhosted.org/packages/3a/5f/47e578b3ae79e2624e205445ab77a1848acdaa2929a00eeef6b16eaaeb20/numpy-1.16.6-cp27-cp27mu-manylinux1_x86_64.whl
Collecting scipy>=0.17.0 (from deeptools)
  Using cached https://files.pythonhosted.org/packages/24/40/11b12af7f322c1e20446c037c47344d89bab4922b8859419d82cf56d796d/scipy-1.2.3-cp27-cp27mu-manylinux1_x86_64.whl
Collecting matplotlib>=3.1.0 (from deeptools)
  Could not find a version that satisfies the requirement matplotlib>=3.1.0 (from deeptools) (from versions: 0.86, 0.86.1, 0.86.2, 0.91.0, 0.91.1, 1.0.1, 1.1.0, 1.1.1, 1.2.0, 1.2.1, 1.3.0, 1.3.1, 1.4.0, 1.4.1rc1, 1.4.1, 1.4.2, 1.4.3, 1.5.0, 1.5.1, 1.5.2, 1.5.3, 2.0.0b1, 2.0.0b2, 2.0.0b3, 2.0.0b4, 2.0.0rc1, 2.0.0rc2, 2.0.0, 2.0.1, 2.0.2, 2.1.0rc1, 2.1.0, 2.1.1, 2.1.2, 2.2.0rc1, 2.2.0, 2.2.2, 2.2.3, 2.2.4, 2.2.5)
No matching distribution found for matplotlib>=3.1.0 (from deeptools)

I run the following command: pip install deeptools

Thanks for your help.

ubuntu python3 deeptools • 51 views
ADD COMMENTlink modified 4 days ago by ATpoint38k • written 4 days ago by DBScan20

Why don't you try installing it using conda?

ADD REPLYlink written 4 days ago by Nitin Narwade450
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 1712 users visited in the last hour