RNA-seq pipeline for degraded RNA
0
3
Entering edit mode
3.1 years ago
oludhe ▴ 60

Hi there,

I have some precious RNA samples that I extracted, and only managed to get RIN scores of between 6.2-6.9 for this tissue (from bone). I have to use these samples and will be going ahead with rRNA depletion and sequenced by Hiseq Rapid 100bp Single read flow cell at 37.5 million reads per sample.

What is the best pipeline for this from raw fastq files until differentially expressed genes? I came across a package called DegNorm which tries to alleviate artefacts due to degraded RNA samples, has anybody got any experience with this?

Also, with the pipeline, as I will be doing rRNA depletion and not poly A selection, could you specify two pipelines, one that only takes into account mature RNA that is already spliced and only taking into account gene expression, and the other that would allow the identfication of other RNAs, e.g splice variants and lncRNAs if possible?

Thanks!

RNA-Seq degraded pipeline alignment • 1.3k views
ADD COMMENT
0
Entering edit mode

Hi ogola89, I'm having your same problem and I'm interested in trying DegNorm... Do you manage to get any results on how it works? Any advice? Thank in advance! :)

ADD REPLY
1
Entering edit mode

Hi yussab, yes I did use it and it did give me marginally better results as my samples were only marginally degraded (between 6 and 7 RIN score). I would suggest you use it. It worked well with the STAR aligner too.

ADD REPLY
0
Entering edit mode

thank you very much for your feedback, I really appreciate it. Unfortunatelly I have more degradaded (as precious) RNAs. DegNorm seems to work fine, you added it to your normal pipeline? After STAR aligment? Are there any tricky step or errors to avoid? 💩

ADD REPLY
1
Entering edit mode

Yea should probably be more important with more degraded RNA. I just used it in my normal pipeline after STAR alignments and it outputs a corrected/normalised CSV so that's what I would use in downstream analysis

ADD REPLY
1
Entering edit mode

Thank you oludhe for posting this and @yussab for the questions. I'm trying to run DegNorm now, it has been running for ~10 hours with no output for the last 5, has only written output for a single sample - is this normal? Roughly how fast did it run for you if you remember?

Edit: I was using python version, which I'm now told is deprecated and I should use the R version! So that settles that.

ADD REPLY
0
Entering edit mode

Nicee.. At the end I had to renounce because I didn't have enough resources, but for the subsets test that I made it work great! How was your feedback?

ADD REPLY

Login before adding your answer.

Traffic: 2530 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6