Circos Gd Module Error
2
0
Entering edit mode
11.1 years ago
datanerd ▴ 520

Hi all,

So Iam trying to use circos for the very first time. I installed all the required modules and also ran the example plot. It ran fine and generated the plot. But now when Iam using it again, it shows an error with GD module saying there is a problem with OTF file (fonts). I then used the instruction to debug, and I all that is needed i.e freestyle stuff. I then tried installing GD using CPAN, but it says its up to date. Does anyone know what the problem might be? I will post the exact error once in the office. Thanks in advance!

• 3.4k views
ADD COMMENT
0
Entering edit mode

just a though: I noticed that GD 2.49 was released a couple days ago. Perhaps if you installed GD 2.46 your issues might be resolved. Also there is a circos google group that can help you.

ADD REPLY
0
Entering edit mode

Thanks Zev. Maybe I will check with GD 2.46 then. Couple of days? so this might be the reason that it ran just fine before but not anymore, isnt it?

ADD REPLY
1
Entering edit mode
11.1 years ago
Josh Herr 5.8k

So, Installing Circos and getting it running was a whole day ordeal for me, mainly because I had to update a lot of CPAN stuff. This blog post was pretty essential for me finding a solution to conflicting dependencies (for which GD is required). I would check on what Zev points out first, but that blog post helped get Circos working for me.

ADD COMMENT
1
Entering edit mode

Thanks Josh :) really it takes time to set circos up. But its worth it when you get your pretty plot. BTW, my problem is solved -i manually installed the module..

ADD REPLY
0
Entering edit mode
11.1 years ago

If you want to accomplish something like circos for the web, be aware of d3.js javascript library capabilities.

ADD COMMENT
0
Entering edit mode

great! this seems cool! Thanks :)

ADD REPLY

Login before adding your answer.

Traffic: 2036 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6