trinity run_DE_analysis.pl Failed with error: ‘package ‘limma’ could not be loaded’
1
0
Entering edit mode
2.7 years ago
Rajesh ▴ 10

Hi Experts, can someone please help me with this error while running run_DE_analysis.pl for DESeq2 analysis

Loading required package: edgeR
    Loading required package: limma
    Error: package or namespace load failed for ‘limma’:
    .onLoad failed in loadNamespace() for 'limma', details:
    call: library.dynam("limma", pkgname, libname)
    error: shared object ‘limma.dylib’ not found
    Failed with error:  ‘package ‘limma’ could not be loaded’
    In addition: Warning messages:
    1: package ‘edgeR’ was built under R version 3.6.2 
    2: package ‘limma’ was built under R version 3.6.2 
    Error: With R version 3.5 or greater, install Bioconductor packages using BiocManager; see https://bioconductor.org/install
    Execution halted
    Error, cmd: Rscript GSE123456.matrix.disease_vs_healthy.DESeq2.Rscript died with ret (256)  at run_DE_analysis.pl line 758.

the same is working on other machines but not on this perticular one. DESeq2, edgeR and limma are already installed in R and working . error is same for trinity 13.1 or 13.2.

run_DE_analysis.pl trinity • 1.3k views
ADD COMMENT
0
Entering edit mode
2.7 years ago
Mensur Dlakic ★ 27k

It says it right there in your error message:

error: shared object ‘limma.dylib’ not found
Failed with error:  ‘package ‘limma’ could not be loaded’

and

1: package ‘edgeR’ was built under R version 3.6.2 
2: package ‘limma’ was built under R version 3.6.2 
Error: With R version 3.5 or greater, install Bioconductor packages using BiocManager; see https://bioconductor.org/install

It seems that you don't have limma installed properly, or at all. Also, it may be that your R is v3.5 while the two packages are for v3.6.2. Either way, you may need to re-install limma, and possibly edgeR as well.

If you know that it works on other machines, why don't you use them?

ADD COMMENT
0
Entering edit mode

I know the error points something wrong with limma and edgeR. I tried re-installing them and it went throguh well as both working in R. Aalso tried using same version of R that is instaleld on the other machines where its working but the same error keep coming in this perticular one. I dont know why ? Ofcourse, I can use other systems but wanted to know why this is not working on this machine. I asked this question if anyone also came across this issue ?

ADD REPLY

Login before adding your answer.

Traffic: 1563 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6