Alphafold in Linux - HHblits error
0
0
Entering edit mode
8 days ago

When I try to run alphafold on a cluster from the ubuntu shell, I am getting this error in HHBlits:

RuntimeError: HHblits failed

stdout:

stderr:

17:40:03.749 ERROR: Could find neither hhm_db nor a3m_db!

Does anybody know why this might be happening? I assumed it would be an issue with the path specification to the database, but my specification to the bfd database is set up as shown:

--bfd_database_path /data/belmont/alphafold-2.2.2-20221214/bfd/bfd_metaclust_clu_complete_id30_c90_final_seq.sorted_opt \

and I have checked that the path is correct:

$ls /data/belmont/alphafold-2.2.2-20221214/bfd

gives:

bfd_metaclust_clu_complete_id30_c90_final_seq.sorted_opt_a3m.ffdata

bfd_metaclust_clu_complete_id30_c90_final_seq.sorted_opt_a3m.ffindex

bfd_metaclust_clu_complete_id30_c90_final_seq.sorted_opt_cs219.ffdata

bfd_metaclust_clu_complete_id30_c90_final_seq.sorted_opt_cs219.ffindex

bfd_metaclust_clu_complete_id30_c90_final_seq.sorted_opt_hhm.ffdata

bfd_metaclust_clu_complete_id30_c90_final_seq.sorted_opt_hhm.ffindex

My full call to alphafold:

alphafold \
--data_dir /data/belmont/alphafold-2.2.2-20221214/ \
--uniref90_database_path /data/belmont/alphafold-2.2.2-20221214/uniref90/uniref90.fasta \
--mgnify_database_path /data/belmont/alphafold-2.2.2-20221214/mgnify/mgy_clusters_2018_12.fa \
--bfd_database_path /data/belmont/alphafold-2.2.2-20221214/bfd/bfd_metaclust_clu_complete_id30_c90_final_seq.sorted_opt \
--uniclust30_database_path /data/belmont/alphafold-2.2.2-20221214/uniclust30/uniclust30_2018_08/uniclust30_2018_08 \
--uniprot_database_path /data/belmont/alphafold-2.2.2-20221214/uniprot/uniprot.fasta \
--pdb_seqres_database_path /data/belmont/alphafold-2.2.2-20221214/pdb_seqres/pdb_seqres.txt \
--template_mmcif_dir /data/belmont/alphafold-2.2.2-20221214/pdb_mmcif/mmcif_files \
--obsolete_pdbs_path /data/belmont/alphafold-2.2.2-20221214/pdb_mmcif/obsolete.dat \
--uniref90_database_path /data/belmont/alphafold-2.2.2-20221214/uniref90/uniref90.fasta \
--mgnify_database_path /data/belmont/alphafold-2.2.2-20221214/mgnify/mgy_clusters_2018_12.fa \
--bfd_database_path /data/belmont/alphafold-2.2.2-20221214/bfd/bfd_metaclust_clu_complete_id30_c90_final_seq.sorted_opt \
--uniclust30_database_path /data/belmont/alphafold-2.2.2-20221214/uniclust30/uniclust30_2018_08/uniclust30_2018_08 \
--uniprot_database_path /data/belmont/alphafold-2.2.2-20221214/uniprot/uniprot.fasta \
--pdb_seqres_database_path /data/belmont/alphafold-2.2.2-20221214/pdb_seqres/pdb_seqres.txt \
--template_mmcif_dir /data/belmont/alphafold-2.2.2-20221214/pdb_mmcif/mmcif_files \
--obsolete_pdbs_path /data/belmont/alphafold-2.2.2-20221214/pdb_mmcif/obsolete.dat \
--fasta_paths CCL5_HD2.fasta \
--max_template_date 2022-01-01 \
--output_dir out/ \
--model_preset multimer \
--use_gpu_relax
linux alphafold • 302 views
ADD COMMENT
0
Entering edit mode

Your command and database location appear correct. I would guess that you have an old version of HHblits which required different file names. If you type only hhblits it should say the version number at the top of screen output. I think version 3.1.x is the minimum requirement, but it could be that 3.3.x is needed.

ADD REPLY
0
Entering edit mode

Just checked, alphafold does seem to be using hhblits 3.3.0. Here is the call that it makes to hhblits if it sheds some light - I can't seem to find the error in it though:

Launching subprocess "/apps/eb/2020b/skylake/software/HH-suite/3.3.0-gompi-2021a/bin/hhblits -i /tmp/80146893.1.short.qg/tmpxbqvuwqg.fasta -cpu 4 -oa3m /tmp/80146893.1.short.qg/tmpgxnus2c_/output.a3m -o /dev/null -n 3 -e 0.001 -maxseq 1000000 -realign_max 100000 -maxfilt 100000 -min_prefilter_hits 1000 -d /data/belmont/alphafold-2.2.2-20221214/bfd/bfd_metaclust_clu_complete_id30_c90_final_seq.sorted_opt -d /data/belmont/alphafold-2.2.2-20221214/uniclust30/uniclust30_2018_08/uniclust30_2018_08"
ADD REPLY

Login before adding your answer.

Traffic: 2234 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6