Problem with mamba/conda env create
0
0
Entering edit mode
10 months ago
tsogurlu • 0

Hello everyone,

I am new into this creating environment thing and not an expert in bioinformatics. So I do not know maybe this is a dumb question. I try to install packages, however I encountered with this warning message:

Command: 
mamba env create --quiet --file "/cta/users/tsogurlu/2023/pipeline/.snakemake/conda/9b5c4f48c50437d93c14f2f0fe0ccc67.yaml" --prefix "/cta/users/tsogurlu/2023/pipeline/.snakemake/conda/9b5c4f48c50437d93c14f2f0fe0ccc67"
Output:
Encountered problems while solving:
  - nothing provides libzlib >=1.2.11,<1.3.0a0 needed by samtools-1.15-h1170115_1

However when I have checked the libzlib (whatever it is) by:

conda list | grep libzlib 

I got:

libzlib                   1.2.13               hd590300_5    conda-forge 

So what is the problem ? The version is already bigger than libzlib >=1.2.11. Did I misunderstand the warning message ?

Many thanks

mamba conda • 1.8k views
ADD COMMENT
1
Entering edit mode

Did you specified your channels in the install command? (e.g. mamba install -c conda-forge -c bioconda samtools=1.15 ....) Could you share your install command?

ADD REPLY
0
Entering edit mode

OP do this, very good chance your problem is the lack of conda-forge channel

ADD REPLY
0
Entering edit mode

Hi, Since this is a pipeline, I do not know. I have searched for the installing command. While searching, I realized that the problem is, I guess, is related to creating environment rather than installing.

Command: 
mamba env create --quiet --file "/cta/users/tsogurlu/2023/pipeline/.snakemake/conda/9b5c4f48c50437d93c14f2f0fe0ccc67.yaml" --prefix "/cta/users/tsogurlu/2023/pipeline/.snakemake/conda/9b5c4f48c50437d93c14f2f0fe0ccc67"
Output:
Encountered problems while solving:
  - nothing provides libzlib >=1.2.11,<1.3.0a0 needed by samtools-1.15-h1170115_1
ADD REPLY
0
Entering edit mode

you should have, somewhere in your snakemake project an environment file (in yaml or json format). Check if conda-forge is in a specified channel in this file

ADD REPLY
0
Entering edit mode

current samtools is 1.19, why do you need 1.15 ? https://github.com/samtools/samtools/releases/

ADD REPLY
0
Entering edit mode

To tell the truth, I am using a new pipeline. The creators chose to install this version. I've just tried to run it. Maybe I can give this feedback to them. Do you have any idea about my problem ? I would really appreciate any suggestion.

ADD REPLY

Login before adding your answer.

Traffic: 1834 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6